Composer Professional Edition Getting Started
Composer Pro Getting Started

Control4 Disclaimer
Control4® makes no representations or warranties with respect to this publication, and specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose. Control4 reserves the right to make changes to any and all parts of this publication at any time, without any obligation to notify any person or entity of such changes.

Trademarks
Control4 and the Control4 logo are registered trademarks of Control4 Corporation. Other product and company names mentioned in this document may be the trademarks or registered trademarks of their respective owners.

Legal Notice

GNU
GNU GENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION (Section 3.b.)
You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:
Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 on a medium customarily used for software interchange.
The complete text for this license is available on the Control4 website at: http://www.control4.com.

Gracenote
Gracenote®, Gracenote logo and logotype, and the “Powered by Gracenote” logo are either a registered trademark or a trademark of Gracenote, Inc. in the United States and/or other countries.
Music and DVD recognition technology and related data are provided by Gracenote®.
Gracenote is the industry standard in Music and DVD recognition technology and related content delivery. For more information visit www.gracenote.com.

MPEG
Fraunhofer IIS and Thomson. MPEG Layer-3 audio coding technology licensed from Fraunhofer IIS and Thomson. Supply of this product does not convey a license nor imply any right to distribute content created with this product in revenue-generating broadcast systems (terrestrial, satellite, cable, and/or other distribution channels), streaming applications (via Internet, intranets, and/or other networks), other content distribution systems (pay-audio or audio-on-demand applications, and the like) or on physical media (compact discs, digital versatile discs, semiconductor chips, hard drives, memory cards, and the like). An independent license for such use is required. For details, visit http://mp3licensing.com. Radio Locator is the service provider of AM/FM channel list.

© 2005-2008 All Media Guide, LLC provides music and video recognition technology that provides cover art and related text that enriches the Control4 user Navigators.

Copyright
© 2010 Control4. All rights reserved. Control4, Control4 logo and Everyday Easy are registered trademarks or trademarks of Control4 Corporation in the United States and/or other countries. All other brands or names may be claimed as property by their respective owners. Pricing and specifications subject to change without notice.

No part of this publication may be reproduced, photocopied, stored on a retrieval system, or transmitted without the express written consent of the publisher.

Contact Information
Control4 Corporation
11734 S. Election Road
Salt Lake City, UT 84020 USA
http://www.control4.com

Part number: 200-00168
Composer Professional Edition Getting Started (OS 2.0)
Contents

1. Introduction ................................................................................................. 6
  1.1 Purpose ................................................................................................ 6
  1.2 Related Documents and Resources .......................................................... 6
  1.3 Composer Pro Overview ........................................................................... 6
      1.3.1 Setting Up the Control4 System – Overview ..................................... 7
  1.4 Composer Pro System Requirements ......................................................... 8
2. Installing the Hardware and Software ......................................................... 9
  2.1 Installing and Connecting the Hardware ................................................... 9
  2.2 Installing Composer Pro Software ..........................................................11
      2.2.1 Procedure .....................................................................................12
3. Exploring Composer Pro Features ...............................................................13
  3.1 Composer Pro Startup Options ................................................................ 14
      3.1.1 Start Composer .............................................................................14
      3.1.2 Exit Composer .............................................................................16
  3.2 Composer Pro Views ................................................................................16
      3.2.1 Available Views ...........................................................................16
4. Connecting to a Director ...............................................................................79
  4.1 Connecting to a Virtual Director ...............................................................80
      4.1.1 Saving Changes When Working Virtually .......................................80
      4.1.2 Using Virtual Mode ......................................................................80
  4.2 Connecting to a Director on a Local Network ...........................................81
      4.2.1 Procedure .....................................................................................82
  4.3 Setting Up Remote Access ......................................................................83
      4.3.1 Prerequisites ...............................................................................83
      4.3.2 Procedures ..................................................................................83
  4.4 Connecting to a Director Using Remote Access .......................................84
      4.4.1 Requirements ..............................................................................84
      4.4.2 Configuring Remote Access ........................................................84
      4.4.3 Connecting Using Remote Access ...............................................86
5. Ensuring that Director and Composer Are Compatible ................................89
6. Designing the Control4 System ..................................................................90
  6.1 Prerequisites ............................................................................................90
Composer Pro Getting Started

6.2 Introduction to Designing a Control4 System ................................................. 90
   6.2.1 Purpose of Device Drivers ................................................................. 92
   6.2.2 Adding Items to the Project Tree ....................................................... 92
   6.2.3 Building a Project in System Design .................................................. 92
   6.2.4 Composer Pro Design Methods ........................................................... 98

7. Making and Testing the Connections ............................................................... 103
   7.1 Connecting the Hardware ......................................................................... 103
   7.2 Testing the Device Connections ............................................................... 104
      7.2.1 Testing Network Connections .......................................................... 104
      7.2.2 Testing Control and AV Connections .............................................. 104
      7.2.3 Testing Room Connections ............................................................... 104

8. Registering the Control4 System ..................................................................... 104
   8.1 Register the System at my.control4.com ................................................. 105
      8.1.1 Register the Controller from Composer .......................................... 105
      8.1.2 Register the System Through a Touch Screen or On-Screen Navigator 108
   8.2 Setting Up a 4Sight Subscription .............................................................. 109
      8.2.1 Prerequisites ..................................................................................... 109
      8.2.2 Procedure ......................................................................................... 109
   8.3 Purchasing and Setting Up Dealer Licenses ............................................. 109
      8.3.1 Prerequisites ..................................................................................... 110

9. What's New in Release 2.0? .............................................................................. 110
   9.1 Hardware, Software, and Media Support .............................................. 110
   9.2 New or Updated Sections ......................................................................... 111
   9.3 Hardware and Software No Longer Supported or Partially Supported .... 111
   9.4 Hardware that Doesn't Support ZigBee® Pro ....................................... 112

10. Where to Go from Here ................................................................................... 112
    10.1 Contacting Control4 Technical Support ............................................... 113

11. Project Build Examples Using System Design .............................................. 113
    11.1 Examples Using System Design ............................................................. 113
    11.2 Example: Using System Design to Add Devices to a Theater Room .... 113
        11.2.1 Procedure .................................................................................... 114
    11.3 Example: Using System Design to Add a Receiver to the Theater Room 117
        11.3.1 Procedure .................................................................................... 117
    11.4 Example: Using System Design to Add a TV to the Theater Room ....... 119
        11.4.1 Procedure .................................................................................... 119

Copyright © 2010 Control4. All Rights Reserved.
Composer Pro Getting Started

11.5 Example: Using System Design to Add a DVD to the Theater Room......................................................... 121
11.5.1 Procedure............................................................................................................................................. 121
12. Glossary....................................................................................................................................................... 123
13. Index............................................................................................................................................................ 128
1. **Introduction**

   Use the Control4® Composer Professional Edition (Composer Pro) application to design and create projects for the Control4 system.

1.1 **Purpose**

   The purpose of this document is to give Dealers and Installers instructions, tips, and examples about how to use the Composer Pro application.

1.2 **Related Documents and Resources**

<table>
<thead>
<tr>
<th>Document file name</th>
<th>Title and location</th>
</tr>
</thead>
</table>
   PDF: [Dealer portal](#) Support > Product Information > User Guides |
   | Control4 System User Guide | PDF: [Dealer portal](#) Support > Product Information > User Guides  
   | Control4 Installation Planning Worksheet | Excel: [Dealer portal](#) Support > Product Information > Accessories |
   | Composer Pro Software Release Update Instructions – 1.8.2 to 2.0 (TechDoc00012) | PDF: [Dealer portal](#) Support > Product Information > Accessories and Knowledgebase |

1.3 **Composer Pro Overview**

   This document is for new Dealers or Installers who want to learn how to use Composer Pro in the Control4® Operating System (OS) Release 2.0 (OS 2.0), or for others who want to keep up with the latest changes. If you are already familiar with Composer Pro, you may only want to know what has changed from the last release. If this is the case, see “What’s New in Release 2.0?” or “Where to Go from Here” for more advanced information about Composer, and then search for your subjects in the Composer Pro User Guide.

   The Control4 system is a combination of Control4 and third-party controllable devices, for example, HDTVs, DVDs, CD players, speakers, home theaters, lights (and so on) that communicate with one another via TCP/IP, infrared (IR), serial, contact, or relay connections.
Composer Pro Getting Started

Composer Professional Edition (Composer Pro) is the software application that Control4 ® Dealers and/or Installers use to design and set up a Control4 system project for home automation in a consumer’s home. The software runs on either a Windows XP, Windows 7, or Windows Vista computer, and provides a powerful graphical user interface UI (user interface) for object-based programming. When connected to a Control4 Controller, the project's information is then communicated to Director on the Controller. Director in turn uses the configuration information and device drivers to communicate to the devices in the Home-Automation System.

The sections in this Getting Started document provide basic information and steps for Control4 Dealers and Installers to become familiar with and start using the Control4 Composer Pro interface for initial design and setup of a Control4 system.

Information beyond the basics (for Intermediate and Advanced users of Composer) is provided in the Composer Pro User Guide.

1.3.1 Setting Up the Control4 System – Overview

Setting up a full-functioning Control4® system includes the following major procedures.

For best results, Control4 recommends that you follow the procedures in this order:

1. **Install and connect the hardware.** When deploying a Control4 system, install and connect the essential hardware:
   - A Control4 Controller (for example, Home Controller HC-300)
   - A Windows-based computer to set up and configure the Home-Automation System using Composer Pro
   - The device to be controlled (for example, Touch Screen, DVD player, speakers, lights, Dock for iPod, etc.)
   - A Controller and PC connection to the home network

2. **Install the Composer Pro software.** Use the Composer Pro installation software to install Composer on a PC and activate it using your my.control4.com Dealer user account.

3. **Connect to a Director** (using a Controller IP address). Each time you start Composer on your PC, you either connect to an existing Director or create a new Director, and then connect to it. Director is the Composer Pro project file (.c4p file) that currently or eventually resides on a Controller to serve as the 'brains' of the system to control each subsystem and device in the Control4 system.
   - **Live Connection:** To make changes to the Control4 system in real time, use a live connection to the Director through either a local connection (via the home network) or a remote connection (via the Internet).

   **Note:** The remote connection must be configured initially using a local connection to the Controller. You can set this up when you create an account.

   - **Virtual Connection:** Alternatively, to create or edit a Director offline and save the Director, use a virtual connection. The saved .c4p project file can be loaded later into a Controller through a local connection to ensure that Director has the most updated system configuration information.

4. **Plan and design the system.** To design a system in Composer Pro, you first create a project in the form of a project tree that represents the hierarchy of locations for the devices to be
automated in the Home-Automation System (site > building > floors > rooms > devices) and the devices that reside in each room.

- **Create a plan.** Creating a plan prior to creating your project in Composer Pro will help make your design go much more smoothly.

- **Choose the design method to use.** Composer Pro provides two (2) methods for building and editing a project.
  - **Easy Method (Interviewer wizard):** The easiest way to create a project is using the built-in Composer Pro wizard called *Interviewer Wizard*, which is available by selecting Run Interview from the File menu in Composer Pro. **Note:** This method is not recommended for advanced projects.
  - **Flexible Method (System Design view):** The most flexible method to use is the default System Design view (preferred by most trained Installers) where you can view the project tree as you build the design.

5. **Make and test the connections.** In the Composer Pro project, you must identify all of the physical connections to the system: control, AV (audio, video), network, and other connections. You can use the Interviewer wizard or the Composer Pro views to complete this task.

6. **Register the system.** Control4 recommends that you register each system you install at my.control4.com to maintain the system software through online downloads.

   **IMPORTANT:** Only registered systems can use all of the media services available. System registration is one of the essential steps in enabling remote access to the system (requires a 4Sight subscription) for repairs, updates, additions, management, etc.

### 1.4 Composer Pro System Requirements

The minimum hardware and software requirements for designing and configuring a Control4® system using Composer Professional Edition include:

- A Control4 Controller (such as a Home Controller HC-300).
- Control4 Composer Professional Edition (Composer Pro) software, version 1.7.4 or later. **Note:** Software version 1.3.0 and earlier do not contain major updates that have been added after this release. Control4 recommends that you update to the latest version. Refer to the "Composer User Guide – Advanced" sections in the *Composer Pro User Guide* to review limitations using Release 1.3.2 and earlier.
- A personal computer (PC) that meets this criteria:
  - Microsoft.NET 1.1 and Support Pack 1 (the Composer install is launched automatically either from a CD, or it is available on the Control4 web site).
  - Microsoft operating systems supported:
    - Windows Vista (64-bit)
    - Windows XP and Service Pack 2 (Home or Professional)
    - Windows 7
  - 500 Mhz or higher processor
  - 256 MB RAM
  - 80 MB hard disk space
  - Video card and monitor supporting a resolution of 1024x768 or higher
  - Keyboard
Composer Pro Getting Started

- Mouse
- 1 to 2 Ethernet (Category 5 or CAT5) cables
- TCP/IP-based (Ethernet) home network. This usually includes a network gateway, router or switch.

Note: A Control4 Controller is set by default as a DHCP client. If the home network has a DHCP server in place (such as a router that provides DHCP services), then the Controller automatically receives a valid IP address.

- A broadband Internet connection. During initial setup, a broadband Internet connection is required to update the Control4 system and retrieve the media's Cover Art. Also, a broadband Internet connection is required to support remote access to the system.

- A wireless access point (WAP) that supports 802.11 b or g (required to use a Control4 Wireless Touch Screen).

- A valid electronic license to run Composer Pro. Starting with OS 2.0 Control4 now requires activation using a my.control4.com account with a license to run Composer Pro. Activation is required every 30 days. See Managing Dealer Accounts on My.Control4.com on the Control4 Dealer web site or Knowledgebase to learn how to add and manage licenses from my.control4.com.

2. Installing the Hardware and Software

This section provides guidelines to install the devices and Composer Pro.

2.1 Installing and Connecting the Hardware

Before you can set up a Control4® Home-Automation System in Composer Pro, all of the devices to be used in the system need to be installed and connected to the home network. Additional devices can be added and identified to the Composer Pro project later.
Follow these guidelines to get started:

1. Create a system specification, and refer to it so you can answer these questions.
   **Tip:** You can use the Control4 Installation Planning Worksheet we've prepared for you to assist you with your configuration planning. After you log in to the Dealer portal, you can find the worksheet in Support > Product Information at the bottom of the ‘Accessories’ list.
   a. What does the home have?
      - Any there any outer buildings, for example a detached garage, that will be automated? All buildings to be automated must be included in the project.
      - How many floors are there in each building? For example, the house has three (3) floors and a basement; the garage has one (1) floor.
      - What rooms are on each floor? For example, the third floor of the house has one (1) Master Bedroom and two (2) other bedrooms. The third floor also has one (1) Master Bath and one (1) Main Bath.
   b. Which Control4 devices are or will be installed in each room (include manufacturers and model numbers)?
   c. Which third-party devices are or will be installed in each room (include manufacturers and model numbers)?
   d. If any of these devices has a choice of power sources, indicate how the device will be powered: AC, Power Over Ethernet (POE), or batteries.
   e. If any of these devices has communication options, indicate how each device will communicate with the Controller (how the device will be controlled): Ethernet, WiFi, ZigBee® Pro, IR, serial, contact, or relay.

2. Install and connect the Control4 devices as described in the Installation Guide that ships with each device.
   **Tip:** There's a link to Control4 documents on the Control4 web site also from the section "Installing Devices" in the Composer Pro User Guide.

3. Install and connect all third-party devices, such as audio-video devices, door contacts, and security panels, as described in the installation guide that ships with each device.

4. Connect the Control4 Controller and your PC to the home network via an Ethernet connection.
2.2 Installing Composer Pro Software

Follow these steps to install your Control4® Composer Pro software for the first time. If you are upgrading the software from early releases, see "Update to 1.7.4 Release Using Update Manager" or "Update to 1.8.2 Release Using Update Manager" in the Composer Pro User Guide or the Release Notes for OS 2.0.

Note: An Internet connection is required to perform this installation.
Follow these general steps for existing systems:

- For Dealer licenses, purchase, install and activate the licenses. The computer running Composer Pro must be connected to the Internet and the Installer must have a my.control4.com account with a license to run Composer Pro. Activation is required every 30 days. See Managing Dealer Accounts on My.Control4.Com on the Control4 web site for details.
- Install Composer Pro.
- Register the system and the Controller.
- Use Update Manager to upgrade to OS 2.0.

### 2.2.1 Procedure

To install the Composer Pro software:

1. Obtain the Composer Installation software (available on CD, **USB** stick, or Web download from the Control4 Dealer web site).
2. Start the Composer installation, and then follow the on-screen instructions.

3. Choose to update to the latest version of Composer.
   
   **Note:** The Composer version or drivers might have been updated after the creation of the CD, USB drive, or Web download. However, Control4 recommends that you always choose to update.

   **Tip:** As new features and drivers become available, the Composer software and associated drivers can be updated. When installation is completed, you can update from the Tools menu, Windows Start, or by running the installation.

4. During the installation process, click **Continue Anyway** to allow the installation to proceed.
Note: If you installed the latest version of Composer on a PC with an older version of Composer, after the update, right-click the My Driver tab and choose Restore Default List. The My Driver list updates.

5. The following screen appears and asks for your Dealer Registration login and password. This assumes that you've already registered on my.control4.com and that you have a 4Sight account. If you don't have a 4Sight account, click the link Don't have a 4Sight dealer account yet? to get one; otherwise, click Register.

3. Exploring Composer Pro Features

The Control4® Composer Pro interface (views) and wizards are designed to help you simplify the process of designing the system, configuring the devices, making the connections, and then customizing the system through the use of programming. How you set up the devices in Composer Pro determines how they will function in the system.

When you start Composer Pro and connect to a Director, the following System Design view appears by default:
The Composer Pro interface contains menus, panes, a project tree, tabs, and objects. All of these components are explained in this document.

3.1 Composer Pro Startup Options

3.1.1 Start Composer

You can start the Control4® Composer Pro application two (2) ways:

- Double-click the Composer icon on your desktop (easiest way).
- Click Start > All Programs > Control4 > Composer 2.x.x > Composer 2.x.x.

When you start Composer, the Composer startup screen displays:
The startup screen presents these Director connection options. Click one of the options to access the Composer project and *project tree*.

- **Virtual Director**—Click this option to work on the project if you are disconnected from the network. If you do not have access to the Controller hardware, you can still set up a system using a "Virtual" Director on your PC, and upload the changes later to the Controller. Using a virtual connection, you can complete most design tasks, including making software connections and performing some programming tasks. You cannot, however, identify network connections, test device control, or set up media virtually.

- **Director on Local Network**—Click this option if you have a direct connection to the home network (inside the firewall). This option gives you all the capabilities of the application: set up and design a project, connect the devices to the network, configure the media, and program the system.

- **Remote Director**—Click this option to work from a remote location by establishing an Internet connection to the home network (outside the firewall). You can perform the tasks as if you were connected using Director on Local Network.

This Directors dialog appears only when you click **Director on Local Network**. In this case, you choose the network address associated with the Controller, and then click **Connect**.
Composer Pro Getting Started

3.1.2 Exit Composer
You can exit Composer two (2) ways:

- From the startup window (where you start Director), click Exit Composer.
- From the File menu (in the Composer project), select Exit.

As you exit, Composer prompts you to back up your project and media information to your local computer. This is not required except when using a Virtual Director connection, but it is always good practice to do so.

3.2 Composer Pro Views

3.2.1 Available Views
The Control4® Composer Pro application has five (5) main views in the bottom left pane. When you select a view (see the figures below), the appearance and functionality of the Composer Pro interface changes to reflect the configuration options for that view.

**Tip:** Collapse the views by clicking the dotted bar just above the views so you have more room to view the project tree.
Main menu:

Composer views:

- **System Design**—Lets you build the *project tree* and identify the devices to the Control4 system.
- **Connections**—Lets you identify all connections (Room, Control, AV, Network).
- **Media**—Lets you add and scan stored or broadcast media.
- **Agents**—Lets you set up an *agent* for use in the system and in programming. Agent types: Lighting Scenes, Wakeup, Scheduler, Variables, etc. Agents are explained in the *Composer Pro User Guide*.
- **Programming**—Lets you program devices and agents on the system.

### 3.2.1.1 System Design View

Use the Control4® Composer System Design view (the default view that appears when you start Composer) to define the Control4 system project for a customer.
This view lets you set up the *project tree* by defining

- The location of the devices to set up in the project (building).
- The *device* you want to include in the project (device objects).
- The location of each device by room (room).

To access the System Design view, start **Composer**.

Notice the three (3) panes in the screen below:

- **System Design (left pane)**—Contains the project tree where you build or update the project configuration with locations and device objects. Double-click an object in the Items pane (see 'Items' in this list) to add it to the project tree in the System Design pane.
- **Properties (center pane)**—Contains the Properties of an object you select from the project tree when you want to check or modify a device, project, and room. Refer to the sections below to view more information about the Properties pane.
  
  "Project Properties"

  "Room Properties"

  "Device Properties"
• **Items (right pane)**—Contains the items (or objects) you use to build your project, such as locations (sites, buildings, floors, rooms) and devices (Controller hardware, DVDs, TVs, Receivers, lights, contacts, relays, etc.). If a device is not available in the My Drivers tab of this pane, use the **Search** tab to search for that device (see the *Composer Pro User Guide* for information about drivers). If you’ve created a new driver using the Driver Wizard (*DriverWorks*), you will find your new driver in the Search tab.

### 3.2.1.1 System Design Pane

The Control4® Composer System Design pane in the System Design view displays the project tree. You build the project tree by adding devices to the tree and in this pane.

To access the System Design pane, start **Composer**.

**Note:** The example project tree below shows the project name, site, building, floors, rooms and devices already added to the project. If your project is new, the pane will show only the New Project icon and item. You can rename your project to whatever you like.
Use the project tree to:

- **Add Locations**—Lets you add locations (sites, buildings, and floors) to the project tree. Double-click to select a location item from the Items pane > Locations tab to move location items to the project tree in the System Design pane. If you do not manually add the locations, Composer automatically adds generic locations.

- **Add Devices**—Lets you add devices (lights, VCRs, TVs, Controllers, etc.) and their device driver to the project tree. To add devices, first click the location (where the device is installed) in the project tree, and then double-click a device in the Items pane > My Drivers or Search tabs (right pane) to move device to the project tree.

For more information about how to create a project, see “Introduction to Designing a Control4 System.”

### 3.2.1.2 Device Control Window

The Control4® Composer Device Control window in System Design lets you test and control a physical device (after identifying its connection) in Composer to make sure it works in the system.

**Note:** You must define the connections before you test or control the devices. See “Testing the Device Connections” for information about how to identify the connections.

**Example:** To use the Device Control for a Dimmer, you click a button in the Composer Device Control window to turn the Dimmer on or off and change the light level. When you do this the physical light changes also if it's working properly.

### 3.2.1.2.1 Procedure

To access the Device Control window:

2. Double-click the device in the project tree to access the Device Control window (see below) for that device.
This window lets you change the configuration parameters (temporarily) and control a device. Later, you can set the parameters permanently in the Properties pane or Programming view.

Example: Adjust and test the ramp rate of a Dimmer to determine the desired ramp rate to set during programming.

3.2.1.1.3 Properties Pane

In the Control4® Composer Pro System Design view, click the project name (top level name) in the project tree to view the project’s Properties.
The project’s Properties appear when you first start Composer Pro, or any time the project name (or root node) is selected in the project tree and the System Design view.

This option lets you enter project-specific information, such as the project name, location, zip code, etc. Composer automatically enters the latitude/longitude and date/time information when you provide the location and zip code.

<table>
<thead>
<tr>
<th>Properties Pane - Project Properties</th>
<th>Category</th>
<th>Boxes or Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Project Name</strong>—Lets you enter/edit the name of the project.</td>
<td>N/A</td>
<td></td>
</tr>
<tr>
<td><strong>Location</strong>—Lets you look up a location’s latitude and longitude based on city, state, country, etc.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Date and Time</strong>—Lets you set a date, time, and time zone for the</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Time zone</strong>—Lets you set the appropriate time zone by clicking <strong>Edit</strong>. Changing the</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Copyright © 2010 Control4. All Rights Reserved.*
### Properties Pane - Project Properties

<table>
<thead>
<tr>
<th>Category</th>
<th>Boxes or Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control4 system. By changing the time here and refreshing Navigators (File &gt; Refresh Navigators), you reset the time on the entire system. However, Control4 systems with access to the Internet automatically synchronize the system clock using Network Time Protocol (NTP).</td>
<td>time zone causes the Controller to reboot.</td>
</tr>
<tr>
<td><strong>Project Settings Control</strong>—Lets you set a device in Composer that does not allow the setting to be overridden at the device.</td>
<td><strong>Push Settings from Project</strong>—Check the box for devices to receive settings from the Composer project only. New settings in the Composer project override any settings at the device.</td>
</tr>
<tr>
<td><strong>System Security</strong>—If set, all Navigators (Release 2.0 and later) must connect through a secure connection.</td>
<td><strong>Secure Connections Only (SSL)</strong>—Check this box if you want all Navigators in this system to go through a secure connection. Click Change Password to change this password. <strong>Note 1:</strong> If the Navigator is not aware of the password restriction, a password prompt appears when the user tries to use the Touch Screen or On-Screen Navigator. Ensure that the user knows the system password in case this ever happens. If the Navigator knows about the password, the password prompt doesn’t appear. <strong>Note 2:</strong> All Navigators that support the older graphical UI will not be required to connect through the secure connection.</td>
</tr>
<tr>
<td><strong>Localization</strong>—Lets you set the locale and character set for countries outside the United States.</td>
<td><strong>Locale</strong>—Use the down arrow to change the locale.</td>
</tr>
</tbody>
</table>
3.2.1.4 Room Properties

The Control4® Composer Room Properties (System Design > Room > Properties) are visible when a room is selected in the System Design project tree.

The Room Properties pane lets you view room-specific device and media information, and helps you troubleshoot any incorrect room connections.

Here, you select Audio or Video Information. Depending on which item you selected, you can view the devices for each type of end point devices and the devices that are in the room’s audio/video (AV) path.

Example: If you can’t play movies from a Disc Changer in a particular room, you can view the room’s Properties to see if the Disc Changer shows up in the List view. If it does not, there are probably missing AV bindings in the path to the device. Detailed information about connections is available in the Composer Pro User Guide or see “Connections View.”

The Room Properties pane also shows you whether Control/Network connections exist for a device.

Example: Perhaps your Disc Changer shows up in the accessible devices, but it might show also that the control connection is not bound correctly.
## Properties Pane — Room Properties

<table>
<thead>
<tr>
<th>Category</th>
<th>Box or Button</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Audio Video Devices tab</strong> — Provides information that lets you view all audio devices, control, and network connections in a selected room.</td>
<td><strong>Audio End Point</strong>—Lets you see the device in the room that outputs the audio (i.e., in the room). <em>Tip:</em> What is the device that outputs audio in the room? <strong>Audio Volume</strong>—Lets you see the device in the room to control audio volume in that room. <em>Tip:</em> What is the device that controls the audio volume in the room? <strong>Video End-Point</strong>—Lets you see the device in the room that displays the video in the room. <em>Tip:</em> What is the video display device or where does the video end up?</td>
</tr>
</tbody>
</table>

| **Navigator tab**—Lets you hide and re-order device visibility for the On-screen Navigator (Radio, Music, TV, Video, Lights, Lighting Scenes, IP Cameras, Pools, Watch, and Listen). | **Modify**—Lets you move the order of devices up or down, and hide or show them. |

| **Miscellaneous view**—Lets you set a default volume for the room, for example, what the room will revert to after a power cycle. This is also where you set the IR Mask for the room. | N/A |
3.2.1.5 Device Properties

The Control4 Composer device properties (System Design > device > Properties) are visible when a device is selected in the project tree. This option lets you modify the available user options on the selected device.

<table>
<thead>
<tr>
<th>Properties Pane — Device Properties</th>
<th>Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>Properties — Lets you modify options (if available) that are common to all devices of that type.</td>
<td></td>
</tr>
<tr>
<td>Advanced Properties — Lets you modify advanced options available on some devices (not available with every device type).</td>
<td></td>
</tr>
</tbody>
</table>

3.2.1.6 List View Pane

Use the Control4 Composer List View pane in System Design to view a device.

When you select a room or any device in a room in the project tree, and then click List View, all of the devices installed in that room display.
3.2.1.6.1 Procedure

To access the List View pane:
1. Start Composer.
2. In the project tree, click any object.
3. In the Properties pane, click the List View tab.
4. You can double-click a device in the List View pane to display its properties.
5. To change the properties of a device, see “Device Properties.”

3.2.1.7 List View Properties

The Control4® Composer List View properties (System Design > device > List View) are visible when an item (such as site, floor, room) is selected in the project tree. This tab lets you view all the devices and their current state.
3.2.1.1.8 **Items Pane**

The Control4® Composer Items pane lets you build the project tree either by:

- Dragging and dropping items from the Items pane to the project tree, or
- Double-clicking the item in the Items pane (which adds it to the project tree).

### 3.2.1.8.1 Procedure

To access the Items pane:

1. Start Composer. The System Design view appears by default.
2. View the Items pane on the right side.
3. Click the **Locations** tab.

---

**Properties Pane — List View Tab**

Lists all the devices in a given room, the current state of contact inputs or other devices. You can monitor and control the devices in the selected location of the project tree.

When selecting the site, building, floor, room, all of the devices associated in that area are visible.

If a device is selected in the project tree, this view shows all devices that are in the same room.
The Locations tab displays the list of available objects by their physical location in the home (site, building, floor, or room) that you can add to a project. Use the items in the Locations tab to organize the project tree by area.

**Example:** The Sites object shows which sites (Home, Work, Corporate, etc.) you can add to your project tree as you build your design.

4. Click the **My Drivers** tab.
The My Drivers tab displays a list of *device drivers* you can add to the project tree. This is a list of common Control4 and third-party device drivers. If you can't find the driver you want, go to Step 5.

5. To locate a driver that is not in the common list, click the **Search** tab. If you can't find the driver you want here, you may need to create your own driver. See the *Composer Pro User Guide* for details to learn how to use the Search function. See "Search Tab."
The Search tab lets you search for drivers that don't appear in the My Drivers tab.
3.2.1.1.9 **My Drivers Tab**

Use the Control4® Composer **My Drivers** tab to add Control4 and popular third-party *device drivers* to the project tree.
3.2.1.9.1 Procedure

To access the My Drivers tab:
1. Start Composer.
2. In the project tree, click any object.
3. In the Items pane (right side), click the My Drivers tab.
   An expandable list of devices for these categories appears:
   - Controllers
   - Lighting
   - User Interface
   - Audio/Video
   - Motorization
   - Sensors
   - HVAC
   - Security
   - IP Cameras
   - Pool and Spa
   - Storage
4. Click to expand a category.
5. Double-click a device driver in the list to add it to the project tree. For information about configuring devices after adding them to the project tree, see "Configuring Devices" in the Composer Pro User Guide.
6. Although the My Drivers list is a subset of all the devices available, you may not see the device driver you need. You can add devices to the My Drivers list using the Search tab.

If you select a generic device, a dialog box with a list of devices appears. Select a specific model to add it to the project tree immediately. If you can't find the device driver you need, you can either modify an existing one or create a new one. See the Composer Pro User Guide for details.

Tip: If you installed Composer Pro Release 2.0 on a computer with an older version of Composer Pro (for example, Release 1.8.x), right-click in the white space below the My Driver tab, and choose Restore Default List. This will update the My Drivers list.

3.2.1.10 Search Tab

Use the Control4® Composer Search tab to search for and add device drivers to the project tree that do not appear in the My Drivers list.

3.2.1.10.1 Procedure

To access the Search tab:
1. Start Composer.
2. In the project tree, click any object.
3. In the Items pane, click the Search tab.
Local Database (default)—The Local Database radio button lets you view device drivers stored on your local computer.

1. To get the device driver, from the project tree select the room where the device resides.
2. In the Search tab, select the Device Type from the drop-down menu.
3. Select the Manufacturer or All Manufacturers from the drop-down menu.
4. Drag-and-drop or double-click the device driver to add it to the project tree.
- **Online Database**—The Online Database radio button lets you view and download devices from the On-Line Database. Follow the same instructions to get this driver as listed above (Local Database).

- **Device Type (required)**—Lets you select the device type, such as AV Switch (includes audio switches), Blinds, CD, Disc Changer (includes DVD and CD Changers), DVD, Light, Receiver, Satellite (includes DVRs), Cable TV, Television, Thermostat, Tuner, VCR and more.

- **Manufacturer**—Lets you select the manufacturer, such as Sony, Mitsubishi, etc. Double-click or drag-and-drop the driver to add it to the project tree.

- **Model**—Lets you select the appropriate model number for a device, such as 45xy67.

- **Device Information**—The Search tab lists detailed information about the selected devices at the bottom of the pane.

Device information includes:

- Model
- Driver creator name
- Date/time the driver was created and modified

**Tip:** Use the Items pane > Search tab > On-line Database radio button to add devices from the On-Line Database. Use the drop-down menus to choose the device type and manufacturer. When the device appears in the pane below, add it to the room in the project tree.

### 3.2.1.1.11 Locations Tab

Use the Control4® Composer Locations tab to add the list of available locations (site, building, floor, room, etc.) to a project.

#### 3.2.1.11.1 Procedure

To access the Locations tab:

1. Start Composer.
2. In the **project tree**, click any object.
3. In the Items pane (right side), click the **Locations** tab.
4. Double-click a location in the tree view of the Locations tab to add it to the project tree.
5. Click **Sites, Buildings, Floors** or **Rooms** to expand the category and expose the location.
- **Sites**—Define the project site type. Defines the main location, and identifies the type of system you are designing, such as a residence, commercial, or corporate.

- **Buildings**—Place the buildings on the site (House, Building, Office, etc.). Defines the buildings located on the site. For example, a residence might have a separate Garage, Workshop, Shed, or Pool house. A Campus might have a building for each college.

- **Floors**—Add the floors in each building (Main, Second, etc.). Lets you describe the various floors in each building, such as Main and Basement or First, Second, and Third floors.

- **Rooms**—Add the rooms on each floor (Bedroom, Bathroom, etc.). Lets you describe the various rooms on a floor, such as Kitchen, Living Room, Great Room, Master Bedroom, Laundry Room, etc.
3.2.1.1.12  Info Pane

Use the Control4® Composer Info pane in System Design to view information about the System Owner and Control4 Dealer.

**Tip:** Some of the information you enter here will be added to the Touch Screens or On-Screen Navigators (More > Settings > About) in Release 2.0 and later. For example, the longitude and latitude is used to display the outside temperature on a Touch Screen or On-Screen Navigator.

3.2.1.12.1 Procedure

To access the List View pane:
1. Start Composer.
2. In the project tree, click any object.
3. In the Properties pane, click the Info tab.
4. View, add or change existing information about the System Owner or Dealer in each box.
5. Check and change the data periodically as needed.

The Info pane lists:
- **System Owner information**
  - Name
  - Address
  - Phone
  - Email address
- **Dealer information**
  - Name
  - Address
  - Phone

---

Copyright © 2010 Control4. All Rights Reserved.
Email address
Primary Contact
Lead Installer
Original Install Date
Date of Last Update

Installation Notes. Use the Notes box to add any relevant details about this particular installation.

3.2.1.2 Connections View

Use the Control4® Composer Connections view to define to the Control4 system the physical connections and addresses of each device added to the Control4 system via the project tree. The connections are added automatically when you add the device.

3.2.1.2.1 Procedure

To access the Connections view:

1. Start Composer.
2. Click Connections at the bottom of the left pane.
3. The Connections pane has two (2) tabs:
   - Control4/AV—Lets you define control and AV connections on the Control4 system.
   - Network—Lets you identify devices on the Control4 system.

The Control & Audio Video Connections pane has two (2) categories and several columns:
• Categories:
  • Control Inputs
  • Room Control

• Columns:
  • **Name**—The name of the device's connection.
  • **Type**—The device type, for example, Control Input or Room Control.
  • **Connection**—This type varies.
  • **Input/Output**—Determines whether the device is for input or output.
  • **Connected To**—Shows the actual connection.

The bottom pane has several columns:

• **Device**—The name of the device.
• **Name**—The same name used in the pane above under Name.
• **Location**—The room name.
• **Connections**—Lists the devices connected.

### 3.2.1.2.2 Control/AV Tab

Use the Control4® Composer Control/AV tab in the Connections view to define the physical connections between the Control4 Controller and other devices you add to the Control4 system, including AV signals, IRs, relays, contacts, and/or serial connections.
3.2.1.2.2.1 Procedure

To access the Control/AV tab:
1. Start Composer.
2. Click Connections at the bottom of the left pane.
3. In the Connections pane, click the Control/AV tab.
4. The Control/AV tab contains two (2) panes.
   - The left pane displays the project tree.
   - The right pane lists the actual device connections.
5. If you click an object in the project tree of the Control/AV tab, you are either selecting a room or a device to display the following types of connections in the Control & Audio Video Connections pane:
   - **Room Connections**—Lets you define the connections specific to the room which can include a Thermostat that you can control from a Touch Screen or On-Screen Navigator. Room connections help you customize and design the devices to perform specific functions in the room.

      If you select a room, for example, Main, on the Control/AV tab, the available room connections appear in the pane under Main (the bar just below Control & Audio Video Connections). The Video, Audio, or Video Audio **end points** and the Audio or Video Audio Volume are all defined for the room.

   - **Control & Audio Video Connections**—If you select a device in the Connections > Control/AV tab, the available Control & Audio Video Connections pane displays the following panes:

      The right pane shows two (2) horizontal panes:

      - **Available inputs and outputs**—The top pane identifies the available inputs and outputs of a device to make its connections.
      - **Connected items**—When you select an item in the top pane, the bottom pane displays the available connection for that input or output.

      To make the actual connection, select the item in the top pane, and drag it to the associated item in the bottom pane.

      **Note:** If you select a device on the project tree and nothing appears, the device doesn’t have any control or AV connections; maybe it uses the network connection to communicate to the Controller. In these cases, use the Network tab to identify this device’s network address to the system. See “Network Tab” below.

      The available input and output categories for the selected device display in this order:

      - **Audio/Video Inputs**—Shows the available audio and video inputs. In this category, the video connections are listed first, and then audio connections.
      - **Audio/Video Outputs**—Shows the available audio and video outputs. In this category, the video connections are listed first, and then the audio connections.
      - **Control Inputs**—Shows the available input control connection.
Composer Pro Getting Started

- **Control Outputs**—Shows the available output control connection.
- **Room Control**—Lists the available room control connections.

If the connections you need do not appear, you can edit the driver to create the needed connections. From the Driver menu (in the Composer menu bar), select **Edit Existing Driver** to open the Driver Wizard, *DriverWorks*.

**Note:** Editing drivers is an advanced task and is out of the scope for this *Composer Pro Getting Started* document. Details about the Driver Wizard are discussed in the *Composer Pro User Guide*.

**Example:** To plug an AV Device into the Wireless Outlet Switch, edit the AV Device driver (such as a Television driver) to see the connection and define to the system the tie between the Television and the Wireless Outlet Switch.

### 3.2.1.2.3 Network Tab

Use the Control4® Composer Network tab in the Connections view to display a list of all devices in the system that have a network connection and use a network address. Identify the network address for any device that communicates to the Controller using TCP/IP, WiFi, ZigBee, or any other device that uses a network address.
### 3.2.1.2.3.1 Procedure

To access the Network tab:
1. Start Composer.
2. Click **Connections** at the bottom of the System Design pane.
3. In the Connections pane, click the **Network** tab. The Network tab displays the network type, for example, IP Network, along with:
   - IP Network Connections pane
   - Available Devices pane

The IP Network Connections pane lists all devices for the selected network type. After identifying
the network connection, the device’s address is displayed in the IP Network Connections pane under Address.

**Buttons**
- **Identify**—Select a device from the IP Network Connections pane and click **Identify** to have Composer identify the device to the network. This puts the device into Identify mode to identify the device's address to **Director**.
- **Disconnect**—Select the device, and click **Disconnect** to remove the connection.
- **Disconnect All**—Click **Disconnect All** to remove all of the connections.

**Columns**
- **Device**—The name of the device.
- **Room**—The room in which the device resides.
- **Type**—The device type recognized by the system.
- **Address Type**—The type of address used, for example, ZigBee.
- **Address**—The device’s MAC address (not the IP address).

**Tip:** You can enter the MAC or IP address manually if preferred.

After identifying the network connection, the device’s address appears. Some addresses are detected automatically—especially when it is the only logical choice in the Control4 system. If a device does not have an address next to it, it needs to be identified to the system or manually entered as shown in “Connecting the Devices.”

The Available Devices pane shows the list of devices that the network has discovered. Each device shows up under the service type. It also displays the total number of devices found and the number of connected or unconnected devices of each type.

**Tip:** Throughout the Control4 system, devices are identified using various types of addresses, such as ZigBee®, ZigBee® Pro, IP, UDP, etc. The documentation refers to these types of addresses as “network addresses.”
3.2.1.3 Media View

Use the Control4® Composer Media view to view and select the stored or broadcast media on the Navigators: the Touch Screens, On-Screen, Mini Touch Screen, and System Remote Control. The Media view lets you add media selections to the Control4 system: stored music and media collections from a network-attach storage device (NAS) or other devices such as a Dock for iPod, DVD Player or Disc Changer, broadcasts, channels, and stations.

To view and select the media from the Navigators, including Wireless Touch Screens, On-Screen Navigator, Mini Touch Screen, and System Remote Control, you first need to add and scan the media to the Control4 Controller (for example, Home Controller HC-1000.) With MP3, FLAC, or AAC files that you add and scan, you can create playlists saved to the Controller (if it has a hard drive) in the Media Database. See the Composer Pro User Guide for details.

Note: The AMG c4lookup service used in previous releases has been switched to Gracenote®. The Sony 777 Disc Changer uses Gracenote, but the Media Controller can no longer access album, title, or artist information from AMG. CDs, however, can be imported and will show up in the Media database with a date and time stamp.

Other Media Managers: You can use other media managers, for example, iTunes, Windows Media player, and Media Monkey to create MP3s. You can still use Composer ME and Composer HE to add files to Control4.
3.2.1.3.1 Procedure

To access the Media view:

1. Start Composer.
2. Click Media at the bottom of the System Design pane.
3. In the Media pane, view the media devices. In the Media view, the left-side selections change the right-side views.

There are three (3) types of media that the system can access and use:

- **Stored** media (such as DVDs) includes the possible media types that store media:
  - **Controller**—Lets you store MP3s in the Digital Audio database of the Controller (if you have a Controller with a hard drive).
    - CD—Lets you store CD Cover Art, albums, the artist ratings, and genre (such as Rock or Country).
    - **DVD Player** or **Disc Changer**—Lets you store DVD and CD (when DVD supports CD) selections by viewing Cover Art, title, info, results, media, and disc list.
    - **MP3 on Digital Audio Player**—Lets you store MP3 — HDD music cover art, album, artist rating, and genre (such as Rock or Country).
    - **External or Network File Storage Devices**—Lets you store MP3, FLAC, or AAC selections on an external hard drive, USB drive, or server.
    - **Screen Saver**—Lets you store the custom images to be used as Navigator screen savers.

- **Broadcast** media (such as Cable/Satellite) includes the possible media types:
  - **Direct TV**—Lets you view Direct TV channel options, including station ID, genre, rating and music channel.
    - **Dish Network**—Lets you view Dish Network channel options, including station ID, genre, rating, and music channel.
    - **Cable TV**—Lets you view Cable channel options, including station ID, genre, rating, and music channel.
    - **UHF/VHF**—Lets you view the UHF channel options, including station ID, genre, rating, and HDTV.
    - **AM/FM/XM**—Lets you scan AM, FM, and XM radio stations.

- **Playlists** includes the possible media types:
  - **MP3 on Digital Audio Player**—Lets you play and view MP3 — HDD music Cover Art, album, artist rating, and genre (such as Rock or Country).
    - CD—Lets you play and view CD Cover Art, albums, the artist ratings, and genre (such as Rock or Country).
    - **Controller**—Lets you play MP3, FLAC, or AAC formats from the Controller.
    - **External or Network File Storage Devices**—Lets you play MP3, FLAC, or AAC selections from an external hard drive, USB drive, or server.
    - **DVD Player or Disc Changer**—Lets you play DVD and CD (when DVD supports CD) selections and view cover art, title, info, results, media, and disc list.
Right-Click Options:

- Right-clicking on a device in Stored media or Broadcast media brings up a number of options:
  - **Clear Media List**—Use Clear Media List with caution because it clears all media from the device, and for a Controller, you will have to start over by adding each album again.
  - **Export Media List and Export Playlist**—Lets you save an XML file of your lists so that if you ever clear your project, you won't have to rebuild the lists.
  - **Import Media List and Import Playlist**—Lets you recover your media lists after you've cleared your project.
  - **New Playlist**—Lets you create a playlist which appears in the Playlists type.

- Right-clicking on **Playlists** displays these options:
  - Export Playlists
  - Import Playlists
  - New Playlist

- Right-clicking on **Actual Playlist** displays these options:
  - Export Playlist
  - Import Playlist
  - New Playlist
  - Delete Playlist
  - Rename Playlist

- Right-clicking on the individual songs in the window below the albums lets you edit song information or delete individual songs.
Possible Buttons:
One or more of these buttons may appear in the middle pane depending on which category you select:

- **Edit**—Lets you edit the information for an existing album or movie.
- **New**—A dialog box opens. You can add information for a new album or movie, etc.
- **Delete**—Lets you remove an existing item from the list.
- **Add**—Lets you add media to your system, for example, MP3, FLAC, or AAC files.
- **Scan**—Lets you scan my.control4.com for music.
- **Configure**—Lets you select the storage device on which the media you're configuring resides.

3.2.1.4 Agents View
Use the Control4® Composer Agents view to perform more complex programming by module.

**Note:** The sections that discuss programming are in the *Composer Pro User Guide*.

3.2.1.4.1.1 Procedure

To access the Agents view:
1. Start Composer.
2. Click **Agents** at the bottom of the System Design pane.
3. In the Agents pane, view the list of agents and their variables.
Available agents include:

- Announcements
- Macros
- Media Scenes
- Email Notification
- Screen Saver
- Timer
- Video Wall
- Variables
- Custom Buttons
- Lighting Scenes
- Scheduler
- Wakeup
- Custom Buttons

**Example:** The Scheduler agent lets you program using dates and times. See “Programming the System” or “Programming with Agents” in the Composer Pro User Guide for definitions and examples.

Common buttons available on some agents in the Agents view are:

- **Add**—Lets you add agents to your system.
- **Remove**—Lets you remove agents from your system.
- **New**—Lets you create a new instance for customizing the selected agent in the Agents pane. For each specific instance of the agent, you provide a unique name and customize it for your specific need.
- **Copy**—Lets you copy an existing instance of the selected agent in the Agents pane.
- **Delete**—Lets you remove an existing instance of the selected agent in the Agents pane.
- **Agent Navigation pane**—Provides each agent a unique interface to set up agent information in a majority of cases for future programming in the Programming view.
- **Save**—Lets you save the agent-specific information. Not all agents require a manual Save option. In most cases, the agent information saves automatically.
3.2.1.5 Programming View

Use the Control4® Composer Programming view to have the Control4 system control devices by identifying to the system any device behavior or configuration options that you want to occur automatically. The Programming view lets you create a program script using the drag-and-drop method.

**Note:** Programming is an advanced function of Composer Pro. Detailed information about programming in this view is explained in the *Composer Pro User Guide*. This section discusses a few of the basics.

All programming is based on events in the Control4 system. For example, a door that opens is an event. When an event occurs in the system, it can trigger other programmed actions to run.

**Example:** When the Bathroom door opens (event occurs), program the Bathroom light to turn on (action taken).

Another example is shown in the figure below. Note the text in the Script pane (middle pane).
3.2.1.5.1.1 Procedure

To access the Programming view:
1. Start Composer.
2. Click Programming at the bottom of the System Design pane.
3. In the Programming pane, view the list of Device Events (see below) and events for the object selected.

The Programming view consists of several panes:
- **Device Events**—Displays all devices that have associated events in the project tree.
- **<Device> or <Room> Events**—Displays the available events for the currently selected device or room in the Device Events project tree. If there are no events for that device or room, none are displayed.
- **Script**—Displays the script associated with the currently-selected event from the Device Events pane. You drag-and-drop an action from the `<Project Title>` Actions pane to arrange the order of actions and nest them in the Script pane.
- **Device Actions**—Displays all available device options with associated actions you can use to write your script.
- **<Project Title> Actions**—Displays the Command, Conditionals, and Loops tabs. You move `Commands`, `Conditionals`, and `Loops` into the Script pane from this pane.

To add an action to the script, you first select the device in the Device Action's project tree, select the type of action you want in the Actions pane, click the **green arrow**, and finally drag-and-drop the action to the Script pane.

- **Commands tab**—Use this tab to select commands (delete, add, etc.) to use for your script.
- **Conditionals tab**—Use this tab to select conditionals (‘if’ statements) to use for your script.
- **Loops tab**—Use this tab to select loops (‘while’ statements, etc.) to use for your script.

3.2.1.5.2 Composer Pro Menu Options

When you start Control4® Composer and connect to **Director**, the menu bar appears at the top of the Composer screen.

The Composer menu bar provides the following menu items:
- **File**—Use this menu to perform typical file management tasks, connect or disconnect to the local Director, launch Interviewer, update both the Composer and Navigator software and exit Composer.
- **Media**—(appears when Media view is selected)—Use this menu to perform tasks regarding music and media lists.
- **Driver**—Use this menu to create, copy, edit or manage drivers to enable devices to work on the system.

---

Copyright © 2010 Control4. All Rights Reserved.
3.2.1.5.2.1 **File Menu**

Access the Control4® Composer File menu from the menu bar on any Composer Pro screen.

<table>
<thead>
<tr>
<th>File</th>
<th>Driver</th>
<th>Go</th>
<th>Tools</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear Project…</td>
<td>Ctrl+N</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Load Project…</td>
<td>Ctrl+O</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Run Interview…</td>
<td>Ctrl+I</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Connect to Director…</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Disconnect from Director</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Backup</td>
<td>Ctrl+S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Backup As…</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Refresh</td>
<td>F5</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Refresh Navigators</td>
<td>Shift+F5</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

From the File menu, you can perform project file management tasks:

1. Manage the project (clear, load, back up, etc.)
2. Connect to Director
3. Launch Interviewer Wizard
4. Refresh Composer Pro
5. Refresh the Navigators: Touch Screens, On-Screen, and Mini Touch Screen

The file management options apply to the files you back up on your computer called project files (project name plus a .c4p extension). Project files are saved by default to the My Documents directory under Control4/Projects.

When you set up a Control4 system, you create project configuration information. This is created live on the Controller hardware, or backed up to a project file on a computer that lets you save specific information about each system, including devices, connections, configuration, programming information, and media. The project configuration is automatically stored on the Controller hardware to which you are connected from your computer. Backing up the project lets you save a copy of the project on your computer.
The following options are available:

- **Clear Project**—Removes any project configuration from the hard drive on the Controller. Composer prompts for a backup before erasing the project configuration information to present a blank project. Use this option with caution.

- **Load Project**—Loads a selected project into the currently-connected Controller. Composer prompts you for a backup before it clears the project configuration information, and replaces it with a selected project you can browse to and load.

- **Run Interview**—Launches Interviewer, a wizard that takes you through the design and setup of a Control4 system. See “Ways to Create a Project in Composer Pro.”

- **Connect to Director**—Connects you to a Director residing on the Controller. When you connect, project configuration information from the Controller is presented to the screen in Composer. This option is available when connected to a Virtual Director.

- **Disconnect from Director**—Disconnects you from a Director. Composer prompts you to back up your project before disconnecting you from the currently-connected Director. This option is available when connected to a Director.

- **Backup**—Backs up the current project to your computer. The first time you back up, Composer prompts you for a filename. It also prompts to back up any media information. If you choose this option, the current project becomes an option in the File > Load Project list.

- **Backup As**—Backs up the current project, and prompts you to enter the name of the file. It also prompts to back up any media information. If you choose this option, the current project becomes an option in the File > Load Project list.

- **Refresh**—Refreshes the current Composer Pro project.

- **Refresh Navigators**—Refreshes the Navigators connected to the system.

### 3.2.1.5.2.2 Media Menu

Access the Control4® Composer Media menu from the menu bar in the Media view.

![Composer 2.0.6 Menu](image)

From the Media menu, you can create, delete, and rename playlists. You can also clear, export, and import media lists. A Media List is the list of media information associated with the selected device, for example, all DVDs with associated Cover Art, title, notes, etc., for each DVD in a Disc Changer.
The media has been scanned or manually added to the Media Database. After you add an item to the Media Database, the Cover Art and information about the media can be viewed and selected from any of the Navigators (Touch Screens, list and On-Screen Navigators, etc.).

- The following options are available:
  - **Clear Media List**—Clears the media list of the selected device from the Media Database.
  - **Export Media List**—Exports a media list for the selected device from the Controller to a PC.
  - **Import Media List**—Imports a media list from the PC to the Controller.
  - **Export Playlists**—Exports a playlist from a Controller to a PC.
  - **Import Playlists**—Imports a playlist from the PC to a Controller.
  - **Import DVD List from File**—Imports an Excel list of DVD titles for a Disc Changer.
  - **New Playlist**—Creates a new playlist from a Controller to a PC.
  - **Delete Playlist**—Removes a playlist.
  - **Rename Playlist**—Renames a playlist.
  - **Tag media files**—Used for OS 2.0 conversion of media files so all media players can see the same tags.

### 3.2.1.5.2.3 Driver Menu

Access the Control4® Composer Driver menu from the menu bar on any Composer screen.

![Driver Menu](image)

From the Driver menu, you can create, copy, or edit drivers. You can also manage the local database of drivers and add other drivers from the Online Database as needed.

**Note:** Creating a new device driver is an advanced procedure. See "Creating Device Drivers" in the Composer Pro User Guide for details.

The following options are available:

- **Create New Driver**—Launches the Driver Wizard and lets you create a new driver based on the typical features of a particular device type, such as DVD players, and TVs. See "Create, Copy and Edit Driver Wizards."
- **Copy Existing Driver**—Launches the Driver Wizard and lets you copy an existing driver model. For example, if a driver exists for a device from a particular manufacturer, but it isn't
the same model, you can modify the driver for the model you need. See “Create, Copy and Edit Driver Wizards.”

- **Edit Existing Driver**—Launches the Driver Wizard and lets you modify an existing driver. This is mostly for testing purposes. After you create a driver, you can test the driver by adding it to the Control4 system to see if it functions correctly. The Edit feature allows you to make modifications when necessary. See “Create, Copy and Edit Driver Wizards.”

- **Add Driver**—Lets you search the Local Database to add a .c4i driver if it doesn't exist in the project. Director will load the new driver, but you will have to add the driver to the project. You can use Update Driver to replace an existing one. This option is used mostly with DriverWorks. See Composer Pro User Guide for details.

- **Manage Drivers**—Lets you manage drivers in your local database and the drivers on the My Drivers tab. See “Manage Drivers Dialog.”

**Tip:** You can also right-click the driver in the project tree to: Rename, Edit Driver, Export Driver, Update Driver, or Delete a driver. New with OS 2.0: Use the same procedure to Update Driver as with Add Driver (see above). However, Update Driver updates your driver if it IS in your project. **Note:** If the driver connection IDs change, the driver will need to be connected again. Double-check your connection after you update your driver.

### 3.2.1.5.2.4 Manage Drivers Dialog

Access the Control4® Composer Manage Drivers dialog from the Driver > Manage Drivers menu item on any Composer Pro screen.

From the Manage Drivers dialog, you can organize the *device drivers* (or drivers) in your Local Database. You can sort by Device Type, Name, Manufacturer, Model, Completeness, Controllability, Creator, Created Date, and Modified Date.

**Buttons**

- **Add**—Lets you add drivers from the Control4 Online Database to the Local Driver Database. When the dialog appears, from the pull-down menus, select the **Device Type** and **Manufacturer** of the device you want to download, and then click **Search**. Check the driver you want to add to the Local Driver Database, and click **OK**. This adds the device driver to your local database.
Composer Pro Getting Started

- **Delete**—Lets you delete a driver from the Local Driver Database.
- **My Drivers**—Lets you add the selected driver to the My Drivers list. In the Manage Drivers dialog, you select a device or use the Shift (to add multiple drivers) or Ctrl keys (to add multiple drivers all in a row).
- **Notes**—Lets you add notes about your drivers.
- **Exit**—Lets you exit the Manage Drivers dialog.

**Other Options**

- **Sort**—Lets you sort and find drivers by column and by Device Type, Name, Manufacturer, Model, Creator, Created Date, Modified Date. Click the top of each column to sort accordingly. Click on the column head to sort the column.

### 3.2.1.5.2.5 Create, Copy and Edit Driver Wizards

To enhance device support in Control4® Composer and in the Control4 system, a device needs a corresponding driver, known as a *device driver*.

If you want to add a device to the Control4 system, and it does not have a supporting driver (or one that you can find in the On-Line Database), you can use the built-in Driver Wizard in Composer Pro to create a driver prior to setting up the device. You can access the wizard from the Driver menu > Create New Driver.

The Driver Wizard lets you add device support to the system for infrared (IR) or serial drivers.

For more information and example implementations, see “Overview of Creating Device Drivers” and “Using the Driver Wizard” in the Composer Pro User Guide.

### 3.2.1.5.3 Go Menu

Access the Control4® Composer Go menu from the menu bar on any Composer Pro screen.
From the Go menu, you can access the various Composer Pro views: System Design (Ctrl+1), Connections (Ctrl+2), Media (Ctrl+3), Agents (Ctrl+4), and Programming (Ctrl+5).

The following options are available:

- **System Design**—Lets you build the project tree and identify the devices in the Control4 system. Access this view with the keyboard shortcut **Ctrl+1**.
- **Connections**—Lets you identify all connections (Room, Control, AV, Network). Access this view with the keyboard shortcut **Ctrl+2**.
- **Media**—Lets you add and scan stored or broadcast media. Access this view with the keyboard shortcut **Ctrl+3**.
- **Agents**—Lets you set up agents for use on the system and programming. Agents include: Lighting Scenes, Wakeup, Scheduler, Variables, etc. Access this view with the keyboard shortcut **Ctrl+4**.
- **Programming**—Lets you program devices and agents on the system. Access this view with the keyboard shortcut **Ctrl+5**.

### 3.2.1.5.4 Tools Menu

Access the Control4® Composer Tools menu from the menu bar on any Composer Pro screen.

From the Tools menu, you can access tools for checking the device connection status.

The following options are available:

- **Network Tools**—Launches the Network Tools window. Composer shows the status of all network devices on the IP Network, ZigBee Network, or EmberNet Upgrade (for upgrades up to Release 1.7.x and later) tabs. The Network Tools window shows you which devices in your project are identified and communicating to the network. See “Network Tools Dialog.”
- **System Manager**—Launches a tool to connect to and configure Control4 Controller hardware and devices. See “System Manager Dialog.”
• **System Diagnostics**—Assists you in gathering system information to help you determine if any issues encountered are configuration problems, performance issues, or potential defects. The System Diagnostics tool is valuable also for logging information and sending email to Control4 Technical Support. See “System Diagnostics.”

• **Account Services**—Facilitates system registration which is required for software updates and to use the media services throughout the Control4 system. It is also required in conjunction with a 4Sight account to enable Remote Access, which allows secure access to your system via the Internet. See “Account Services.”

• **Update Manager**—Lets you update the entire Control4 system. See “Update Manager.”

### 3.2.1.5.5 Network Tools Dialog

Use the Control4® Composer Network Tools dialog to view ZigBee devices, devices on the IP network, and EmberNet Upgrade lists (for upgrades up to Release 1.7.4 and 1.8.2).

From the Tools menu, select **Network Tools**.

![Network Tools dialog](image)

The Network Tools tabs describe the following:

- **IP Network**—Lists the devices on the IP network.
- **ZigBee Network**—Lists information about the ZigBee devices.
- **EmberNet Upgrade**—Lists updated information about ZigBee Pro devices that are being updated. (This applies when you are upgrading from Release 1.7.x to 1.8.x. Refer to the **Composer Pro Software Release Update Instructions - Release 1.7.4 to 1.8.2** in the Control4 Knowledgebase or on the Control4 web site.) The devices appear in this tab temporarily, and then after update, they appear in the ZigBee Network tab.

The icons denote the following:
Green—Indicates that an address is identified and the device is *online*. For example, a Dimmer is identified and communicating to the Control4 system.

Yellow—Indicates that an address is identified and the device is *offline*. For example, if the System Remote Control goes to sleep, the status turns Yellow. This indicates that the System Remote Control has been identified, but it is offline. Activate the device so it can communicate to the Control4 system.

Red—Indicates that a device is not identified. In this case, go to the **Connections** view > **Network** tab and identify the device to the system.

The Network Tools tabs are shown below.

### 3.2.1.5.5.1 IP Network Tab

![IP Network Tab](image)

This shows the IP devices on the network, network addresses, and status.
### 3.2.1.5.5.2 ZigBee Network Tab

You can view the ZigBee network items three (3) ways using these radio buttons:

- **Room Tree**—Takes the devices that are in the project and lists them.
- **Routing Tree**—Takes the devices from the ZigBee server. A device may display several times; there may be many ways that ZigBee communicates with a device and all of those are listed.

If you select the Routing Tree view and nothing appears, the ZigBee devices are not communicating. Under normal circumstances, you can view the display as it changes devices. This is due to the mesh network structure.

- **List**—Takes the devices that are in the project and lists them.
3.2.1.5.5.3 **EmberNet Upgrade Tab (Release 1.8.0 and later)**

This shows the EmberNet Upgrade Controller which is used when you upgrade from Release 1.7.4 to 1.8.2.

3.2.1.5.6 **System Manager Dialog**

From the Control4® Composer Tools menu view network addresses and system status. Select the System Manager dialog to access the following tabs:

- **Network**—Shows the status under Active Interface, IP Address, and DNS Servers. The Configure button launches a Network Configuration Wizard to help you configure your network settings.
• **Status**—Shows the Server Name and Status which shows whether the device is enabled. The Disable and Enable buttons let you select a device to disable or enable.

3.2.1.5.7 **System Diagnostics**

From the Control4® Composer Tools menu, access the System Diagnostics screens. Use these screens to help you diagnose system problems and activity.

• **Controller Performance Tab**—Lets you view Controller performance information, including CPU and memory usage. Process data is listed in the bottom pane.

• **Controller Performance History Button**—Lets you view the history of CPU and memory performance.
Composer Pro Getting Started
• **Controller Networking Tab**—Lets you view Controller networking information, including network type, connection status, MAC address, IP address, Subnet mask, Gateway, DHCP status, and DNS server information.

![System Diagnostics](image)

- **Test Internet Connection Button**—Lets you test the current Internet connection. After viewing, click **Close** to exit the dialog box.

![Test Internet Connection](image)
• **System Info Tab**—Lets you view system information in a tree view. Click **Save To File** to save this information.

![System Info Tab](image)

• **Logging Tab**—Lets you log system problems.

![Logging Tab](image)

• Click **Start Logging** to log information. You can check the items to log and click **Start**.
• Click **Stop Logging** when you no longer want to log information.
• Click **Open Controller Log** to view the log file.
• Click **Auto Scroll Output** to scroll through the log entries.

### 3.2.1.5.8 Account Services

From the Control4® Composer Tools menu, select **Account Services** to set up a my.control4.com account and register a **Controller**, remove a Controller from registration, or check in for a service connection.

#### 3.2.1.5.8.1 Procedure

**To register a Controller:**

1. Click **Register your controller**.
2. Enter your 10-digit code, and then click **Register**.
3. (Optional) To remove a Controller from registration, click **Unregister**. Click **Close**.
You can also check the current account status, and establish a service connection.

- Controller Registration.
- Current Status.
- Enable or disable Remote Access.
- Service Connection. Click **Check In** to establish a connection for service.

### 3.2.1.5.9 Update Manager

To continue to improve our products, periodically the Control4® team needs to develop updated versions of Composer and Director and provide those updates to you. Use Update Manager to update your Composer software.

**Note:** Releases prior to release 1.7.x and after Release 2.0 will use Update Manager as usual. Refer to the *Composer Pro Software Release Update Instructions* - *1.7.4 to 1.8.2* and the OS 2.0 Release Notes for special ZigBee to ZigBee Pro upgrade instructions that are required between Releases 1.7.x and 2.0.
3.2.1.5.9.1 Procedures

To update Director:

1. From the Tools menu, select **Update Manager**.

![Update Manager](image)

2. Click **Update**.

![Update System](image)

3. Click **Begin Update**.

To update the system software:

1. Click **Update** to update the system. After you begin the updates, you cannot modify your project. Do not remove any power cords or Ethernet cables until the updates are completed. You can have an email message sent to you when the update completes to notify you when you can modify the project again. See “Programming with Agents” in the Composer Pro User Guide to set up notifications.

2. To view the project, you can close the **Update Manager** dialog without interrupting the update, but you cannot make any changes.

3. Click **View Logs** in the Update Manager dialog to view the update messages.
4. Click **Cancel Pending** to cancel the device downloads. This action cancels a download from the device.

   **Note:** You cannot cancel an update after the update has begun.

### 3.2.1.5.10 Help Menu

From the Control4® Composer Pro Help menu, you can:

- Access the online Help topics, Index, and Search function for Composer Pro Getting Started.
- Access the online Web Help topics for Composer Pro User Guide. **Note:** Use the links in Composer Pro Getting Started help topics to access the Composer Pro User Guide.
- Check the Composer and Director versions.
- Contact Control4 Technical Support.

![Help Menu](image)

The following options are available:

- **Contents**—Displays the Contents tab of the user help.
- **Index**—Displays the Index tab of the user help.
- **Knowledgebase**—Displays the Control4 Knowledgebase login. The Knowledgebase contains documents, articles, and other sources for reference.
- **About Composer**—Displays the Composer and Director versions.

### 3.2.1.6 Composer Pro Properties

Access the Control4® Composer Properties panes from the System Design view.

There are four (4) categories of properties in a Control4 system: Project, Room, Device, and List View properties.

- Project Properties
- Room Properties
- Device Properties
- List View Properties
3.2.1.7 Accessing Properties from the Project Tree

You can use the Control4® Composer Pro Properties pane to view:

- Devices
- Connections
- Status information
- Project or customer information
- Configuration information for devices and rooms

3.2.1.7.1 Procedure

To access Properties from the project tree:

1. After adding the device and making the connections, select the device from the project tree in the System Design view.
2. Click the Properties tab; the properties for the device appear in the Properties pane.

3.2.1.8 Properties Pane

In the Control4® Composer Pro System Design view, click the project name (top level name) in the project tree to view the project’s Properties.
The project’s Properties appear when you first start Composer Pro, or any time the project name (or root node) is selected in the project tree and the System Design view.

This option lets you enter project-specific information, such as the project name, location, zip code, etc. Composer automatically enters the latitude/longitude and date/time information when you provide the location and zip code.
<table>
<thead>
<tr>
<th>Properties Pane - Project Properties</th>
<th>Category</th>
<th>Boxes or Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Project Name</strong>—Lets you enter/edit the name of the project.</td>
<td></td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Location</strong>—Lets you look up a location’s latitude and longitude based on city, state, country, etc.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Date and Time</strong>—Lets you set a date, time, and time zone for the Control4 system. By changing the time here and refreshing Navigators (File &gt; Refresh Navigators), you reset the time on the entire system. However, Control4 systems with access to the Internet automatically synchronize the system clock using Network Time Protocol (NTP).</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Project Settings Control</strong>—Lets you set a device in Composer that does not allow the setting to be overridden at the device.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>System Security</strong>—If set, all Navigators (Release 2.0 and later) must connect through a secure connection.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Latitude/Longitude</strong>—Lets the system calculate from the entered zip code, the local latitude and longitude coordinate information. Knowing location information lets the system calculate local sunrise and sunset times. This is useful for programming lights to turn on at dusk and off at dawn. Using a zip code to find the coordinates only provides a close estimate of latitude and longitude. If you want to enter exact coordinates, the fields can be edited. Also used for outside temperature on the Touch Screens.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Lookup Button</strong>—Lets you enter/edit the zip code which identifies to the system the local cable, satellite, and broadcast channel programming. It also automatically provides latitude and longitude coordinate location.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Time zone</strong>—Lets you set the appropriate time zone by clicking Edit. Changing the time zone causes the Controller to reboot.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Push Settings from Project</strong>—Check the box for devices to receive settings from the Composer project only. New settings in the Composer project override any settings at the device.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Secure Connections Only (SSL)</strong>—Check this box if you want all Navigators in this system to go through a secure connection. Click Change Password to change this password. <strong>Note 1:</strong> If the Navigator is not aware of the password restriction, a password prompt appears when the user tries to use the Touch Screen or On-Screen</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
3.2.1.9 Basic Composer Tasks
You can perform simple but important tasks in Control4® Composer Pro (see below), or you can take a deeper dive into intermediate or more advanced tasks (the Composer Pro User Guide will show you how).

3.2.1.10 Accessing the List View from the Project Tree
Use the List View tab in Control4® Composer Pro to view the devices in your project (by room).

3.2.1.10.1 Prerequisites
Add the devices and make the connections.

3.2.1.10.2 Procedure
To view the list:
1. Click System Design.
2. Select a room in the project tree.
3. Click the List View tab; the status of each device associated with that room displays in the List View pane.

<table>
<thead>
<tr>
<th>Properties Pane - Project Properties</th>
<th>Category</th>
<th>Boxes or Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td>Localization—Lets you set the locale and character set for countries outside the United States.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Navigator. Ensure that the user knows the system password in case this ever happens. If the Navigator knows about the password, the password prompt doesn’t appear. Note 2: All Navigators that support the older graphical UI will not be required to connect through the secure connection.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| Localization—Lets you set the locale and character set for countries outside the United States. | | Locale—Use the down arrow to change the locale. |
3.2.1.11 Removing Items from the Project Tree
Use the Control4® Composer Pro project tree in System Design to remove devices, rooms, buildings, etc.

3.2.1.11.1 Procedure
To remove items from the project tree or other lists in a Composer project:
1. Right-click the item to remove in the project tree, and select Delete.
2. Click Yes to confirm.

3.2.1.12 Renaming Items in the Project Tree
Use the Control4® Composer Pro project tree in System Design to rename items.

3.2.1.12.1 Procedure
To rename items in the project tree or other lists in a Composer project:
1. Right-click the item to rename in the project tree, and select Rename.
2. Type the new name in the object's title.

3.2.1.13 Clearing a Project
To erase all project configuration information, use the Control4® Composer Pro Clear Project menu option.

Note: Control4 recommends that you create a backup file of your project first before you use this function. To back up the project, go to the File menu, and select Backup. Give the project a filename; the file saves to the My Documents folder by default.
3.2.1.13.1 Procedure
To clear out a project:
From the File menu, select **Clear Project** to erase the project configuration information.

3.2.1.14 Exiting Composer
Use the Exit command to close Control4® Composer Pro.

3.2.1.14.1 Procedure
To exit Composer:
1. From the File menu, select **Exit**.
2. Composer asks you if you want to back up your configuration information.

*Note:* Control4 recommends that you always save a backup copy of your configuration.

3.2.1.15 Getting Project Configuration Information from a Controller
Use the Control4® Composer Pro 'Connect to Director' link to view configuration information.

3.2.1.15.1 Procedure
To get existing project configuration data from a Controller:
1. Verify that your PC and the **Controller** are connected to the same network.
2. From the Composer Startup screen, click **Director on Local Network** or from menu bar, click **File > Connect to Director** (see below). The project configuration appears unless it is a new project.
3.2.1.16 Loading a Project’s Configuration from a Computer to a Controller

Use the Control4® Composer Pro software Connect to Director to load configuration information.

3.2.1.16.1 Procedure

To load the project configuration from a computer to the Controller hardware:

1. Verify that your PC and the Controller are connected to the same network.
2. From the Startup screen, click Director on Local Network, or from menu bar, click File > Connect to Director (see below).
3. From the File menu, select **Load Project**.
4. Click **Yes** when prompted to back up the project. Browse and select the project file.

   **Example:** SmithProject.c4p

5. When you see the new project displayed in the System Design view, the project is loaded to the Controller, and you are connected.
3.2.1.17 Backing Up a Composer Pro Project

Use the Control4® Composer Pro File menu to back up your project.

The File menu in the Composer screens provides the following options for backups:

- **Backup**—Backs up the current project to your PC. The first time you back up, it prompts you for a filename. It also prompts you to back up any media information. If you choose this option, the current project becomes an option in the File > Load Project list.

- **Backup As**—Backs up the current project, and prompts you to enter the name of the file. It also prompts you to back up any media information. If you choose this option, the current project becomes an option in the File > Load Project list.

Anytime you exit Composer File > Exit, Composer asks you if you want to back up your project. If you've made changes, it's a good idea to do so.

3.2.1.18 Backing Up and Loading from a Virtual to a Local or Remote Director

Use the Control4® Composer Pro Connect to Director option to back up a Director.

3.2.1.18.1 Procedure

To back up and load configuration information from the Virtual Director to the Local or Remote Director:

1. From the Composer File menu, select **Connect to Director**.
2. When prompted, click **Yes** or **No** if you want to back up the Media Information.
3. A Directors dialog box appears listing the available Director IP addresses. Select the address of the Controller to which you are connecting.

4. Click **Connect**. You are now connected to a Local Director or a Remote Director.
3.2.1.19 **Backing Up a Project's Configuration and Media**

Use Control4® Composer Pro to back up project information. When connected to the Controller, changes are immediate.

3.2.1.19.1 **Procedure**

To save a project configuration to your computer, and then use the Backup and Backup As options:

1. From the File menu, select **Backup**.
2. Type a filename to back up the project, or use the same name if you prefer.

3.2.1.20 **Backing Up as Project Configuration and Media**

Use Control4® Composer Pro to back up as project information. When connected to the Controller, changes are immediate.

3.2.1.20.1 **Procedure**

To save the project configuration to your computer, and then use the Backup As option:

1. From the File menu, select **Backup As**.
2. Type a filename to back up the project.

**Example:** Jones Project

3. When prompted, click **Yes** or **No** to back up Media information.
4. Connecting to a Director

Each Control4® Controller (for example, a Home Controller HC-500) ships with pre-installed Director software. The Director communicates with Control4 and third-party products to enable Home Automation so devices can communicate with each other and Director.

To configure or update a Control4 system, start Composer Pro and connect to a Director.

Note: If a Composer license is associated with this product, a 'Renew Composer Registration' screen may appear before you can connect to Director. If it does, you must type your email address, password, and then click Renew.

On the Composer Startup screen, you can connect three (3) ways depending on how you want to connect.

In Composer Pro, click the box that represents one of the following options:

1. **Virtual Director**—A connection to a virtual Controller (PC is the Director host instead of the Controller) outside the network. Projects created or edited here are benign until the saved project is loaded onto a Controller. Choose this option to work on a project when you are disconnected from the network. You can do almost everything you need to set up and design a system, set up most connections, and use programming.
   
   **Note:** You cannot identify network connections, test device control, or set up media using this method. See the Composer Pro User Guide for information.

2. **Director on Local Network**—A local live connection to the Controller (the PC is inside a firewall). Changes to the Control4 system are effective immediately. Choose this option to work when connected to the home network (inside the firewall).
   
   **Note:** You can set up and design the project, make connections, add media, and program the system using this method.
3. **Remote Director**—A remote live connection to the Controller over the Internet (the PC is outside the network firewall). Changes to the system are effective immediately. Choose this option to use an Internet connection to the home network.

   **Note:** You can do everything as if you were hooked up to the Local Network using this method.

Choose a connection option, and then refer to following sections for specific instructions about how to connect.

### 4.1 Connecting to a Virtual Director

If you connect to a Control4® Composer Pro Virtual Director, you are working in Virtual Director mode. This means you are not connected to the Control4 Controller and the home network, and changes are not automatically saved in real time to the Control4 Controller.

#### 4.1.1 Saving Changes When Working Virtually

The only way your changes are saved is if you manually use the **Backup As** or **Backup** option from the File menu to save the project file.

While in Virtual Director mode, you can save your project changes manually using the File menu **Backup As** or **Backup** option. The project file saves by default with a `.c4p` extension to your My Documents directory on your computer.

#### 4.1.2 Using Virtual Mode

After you have designed and set up a system in Virtual Director mode, you can load the project to the Controller.

The Load Project option is available from the File menu. This mode is useful, for example, if you are using a laptop PC, and you can't connect to the network.

- If you change the project, you can connect to the network and synchronize your changes to the Controller when you're ready to.
- If you design and set up a system in Virtual Director mode, you can later load the project to the Controller. In the File menu, the **Load Project** option is available for synchronization.

#### 4.1.2.1 Procedure

**To connect to a virtual Director:**

1. Start **Composer**.
2. At the Composer Startup screen, click **Virtual Director**. Virtual Director lets you work in Composer while disconnected from a Director. Composer opens to the main Composer view in Virtual Mode.
The System Design view appears by default.

### 4.2 Connecting to a Director on a Local Network

When you connect to a Control4® Composer Pro Local Director, you are making 'live' changes on the Controller. Every time you connect to that Director, you see your project configuration.

**Tip:** You also have the option to make a backup of the project on your computer by using the **Backup As** or **Backup** option from the File menu to save the project file. When you back up a project file, it is backed up by default to the *My Documents* directory on your computer.
4.2.1 Procedure

To connect to a Director locally:
1. From the desktop, double-click the Composer x.x.x icon.
2. At the Composer startup screen, click Director on Local Network. Local Director connects you to the home network while working in Composer Pro.

3. From the Director dialog box, choose the Director’s network address for the Controller you are setting up, and then click Connect.
4. Make a note of the network’s IP address. Composer Pro opens to the Composer System Design view.
4.3 Setting Up Remote Access

Use a Control4 Navigator to set up Remote Access. This feature lets you access your Control4 system for updates using the Internet from a remote location. **Note**: You can also set up Remote Access when you create an account at my.control4.com.

4.3.1 Prerequisites

1. Register the system at [my.control4.com](http://my.control4.com).
2. Control4 recommends that a 4Sight subscription be set up for remote access (subscription sold separately).
3. This process can be completed by the Installer or homeowner as long as the system has been registered at [my.control4.com](http://my.control4.com).

4.3.2 Procedures

**To set up Remote Access for releases earlier than OS 2.0:**

1. At one of the Navigators, select **Info** (releases earlier than OS 2.0).
2. Select **Remote Access**.
3. Select **Remote Access > Activate**.

**To set up Remote Access for OS 2.0 and later:**

1. At one of the Touch Screens or On-Screen Navigators, select **More > Settings**.
2. Select **Remote Access**.
3. Select **Remote Access > Enabled**.

**Note 1**: After you enable remote access, if the user has a 4Sight subscription for this system, then the user can enter their email address and password, and securely log in to their Control4 home network from any Internet connection in the world. When the user logs in, the homeowner can use the Web Navigator to monitor and control their lights, change their temperature (warm or cool the home remotely), or check whether any doors or windows were left open. You or the user can refer to this Internet information in the *Control4 System User Guide, Rev. G (OS 2.0)*.

**Note 2**: If this system and Controller are registered on my.control4.com, the system is accessible for remote access (without a 4Sight subscription) after a request by the Control4 Installer or Control4 Technical Support has been made to access the system on my.control4.com AND the system user (Installer or homeowner) instructs the Controller to “check in.” The homeowner can do this from the Navigator’s Remote Access page. The Installer can set up a “Check In” from Composer using **Tools > Account Services** menu option.
4.4 Connecting to a Director Using Remote Access

If you connect to a Control4® Composer Remote Director, you are making "live" changes to a remote system **Controller**, where changes are communicated over an Internet connection rather than a local network connection. This type of connection is not available, however, until the initial configuration and registration are completed.

A remote connection requires either a temporary connection granted by the user, or a persistent connection to the system made available by setting up a 4Sight Internet Services subscription.

- **Temporary Connection.** If the customer is registered on [my.control4.com](http://my.control4.com), their Controller registration is completed, and remote access is enabled. The system is accessible for temporary Remote Access after the Control4 Installer or Technical Support person requests system access through my.control4.com, AND the customer instructs the Controller through a Navigator to 'Check In.' See "" for more information, see “Setting Up Remote Access.”

- **Constant Connection.** If the customer purchased a 4Sight subscription AND activated the subscription for their Controller through my.control4.com, then the system is always online and accessible for immediate remote access.

**Note:** The customer may revoke access rights through [my.control.com](http://my.control.com) at any time, but this is not recommended as it interferes with routine Control4 updates.

4.4.1 Requirements

- The customer must be registered at my.control4.com and Remote Access must be enabled. (See “Registering the Control4 System” or “Register the System Through a Touch Screen or On-Screen Navigator.”)

- The customer must EITHER own a 4Sight subscription (sold separately) and have it activated OR make a temporary connection using the 'Check In' feature in Composer and a Navigator.

- If using 4Sight, obtain a 4Sight subscription for your customer and activate the subscription as described in “Setting Up Remote Access.”

- A PC with Composer initially installed must be in the same local network as the Controller when Remote Access is set up.

Before you can use the Remote Director connection option, you must configure the system to support Remote Access (see "Registering the Control4 System").

4.4.2 Configuring Remote Access

**To configure Remote Access:**

1. Ensure that the computer and Controller are on the same physical location and connected via an Ethernet connection.
2. From the Composer startup screen, click **Director on Local Network**.
3. From the Director dialog, choose the Director’s network address of the Controller hardware you are setting up, and click **Connect**.

Choosing the Local Director is essential to Remote Access setup, as it defines to the system the Controller you want to use to log into the Remote Access service.

Perform this step at the same physical location as the Controller to give you Remote Access to that system. If necessary, click **Add** to add the address manually.

4. From the Tools menu, choose **Account Services** to start the registration process.

5. Complete the steps on the Account Services page which includes clicking the link to create or edit a my.control4.com account AND doing one of the following:
Composer Pro Getting Started

- Activate a 4Sight Internet Services subscription for a continuous connection.
- Establish a temporary connection using the **Check In** option.

For detailed instructions about configuring Remote Access, see “Registering the Control4 System” and “Setting Up a 4Sight Subscription.”

---

6. From the File menu, click **Exit** to exit Composer.

### 4.4.3 Connecting Using Remote Access

**To connect to Remote Director:**

1. Using a PC with Composer installed, obtain a remote Internet connection (an Internet connection that is not in the same computer network as the actual Controller).
2. From the desktop, start **Composer**.
3. At the Composer startup screen, click **Remote Director**. Remote Director connects you to the home network while working in Composer from a remote location.

---

Copyright © 2010 Control4. All Rights Reserved.
4. When the Select Remote Account dialog box appears, select the account you want to access, and click **Connect**.

If the account name doesn't appear under *MyControl4 Account Name*, click **Add** to add the account name, and click **OK** in the dialog box that appears. This is the Account Name you created during registration at my.control4.com. After you do this, repeat Step 4.
5. When the Connect to <User email address> dialog box appears, enter the User Email Address and Password, and then click **Connect**.

The next screen shows that your account, the User Email Address, and the Password are being verified. This may take several minutes to complete as it is accesses a remote connection.

When authenticated and connected through the MyControl4 Remote Access Service, a list of Directors available for connection appears.

6. Select the Director you want to connect to, and click **Connect**.

When connected, Composer opens and the main Composer view connects to the Controller remotely. Composer functions normally as if you were connected to Local Director, allowing you to configure, program, and troubleshoot the Control4 system.
5. **Ensuring that Director and Composer Are Compatible**

Verify that the Control4® Controller software (called Director) and the Composer software are on the same version before beginning to design a project, or any time you use Composer to ensure the best communication between the two.

In the Composer menu bar, click Help > About Composer.

From the dialog that appears, compare the Composer and Director version numbers. For the Control4 system to run properly, these numbers need to match. If they don’t match, update Composer and/or Director to the same version. See the Composer Pro User Guide for information about updating your system, or see “Update Manager.”

**Example:**

Composer version: 2.0.0.67890  
Director version: 2.0.0.69543

Note that the two versions in the screen below are *not* the same.
6. Designing the Control4 System

Become familiar with the Control4® Composer design options before you start to build your first project and project tree. The project tree represents the hierarchy of locations (sites, buildings, floors, and rooms) AND devices in each room. You will add all types of controllable devices to the Control4 system, including audio/video, multi-room audio, lighting, motorization, sensors, relays, and other devices.

Here are some sections that might interest you as you prepare to design a system:

"Introduction to Designing a Control4 System"
"Ways to Create a Project in Composer"
"Purpose of Device Drivers"
"Adding Items to the Project Tree"
"Using the Interviewer Wizard to Build a Project"
"Using Composer Views to Build a Project"

6.1 Prerequisites

In most cases, it's good to make a list of the actual devices to be used in the project, the manufacturer and the model number. You will need this information as you build the project. Also, before you start, create a plan for your project.

Tip: It might be worth your while to check out some cool project management programs called "Smart Office" and "Control Integration" by Simply Reliable. These products help you manage your projects from creating home automation proposals to integration of devices into a Composer project.

6.2 Introduction to Designing a Control4 System

Designing a Control4® system in Composer is similar to designing a house. You start with the plan; then you build the foundation; you build the framework; and then you add the electrical, plumbing, walls, carpets, paint, etc. to finish the home.

To give you a 'bird's eye view' about how to design and implement a Control4 system, you

- Create a plan. This includes the devices to be used, where they will reside in the home, and how the network will be set up.
- Install and connect the Control4 and third-party devices that need to communicate to the network. **Note:** Many Control4 or third-party devices may be installed already.
- Connect these devices to each other and to the Controller(s) so they all communicate with the Controller and the home network.
- Build the framework called a project tree using the System Design view in Composer. This includes adding objects to the project tree that represent the physical buildings, rooms, and devices. **Note:** You can connect a physical device, and then add it to Composer one at a time if you prefer.
- Identify and virtually connect all of the devices in Composer. In addition to the hardware connections, you have to connect your devices the same way in the Composer software also.
Customize the behavior of the devices in Composer and on the Navigators. To customize the devices for specific functions, you program events and actions, Lighting Scenes, agents, and so on for your customers' needs. Many custom functions can be performed on the Touch Screens and On-Screen Navigators. See the Control4 System User Guide and Control4 Quick Start Guide (OS 2.0) for more information.

Designing a full-functioning Control4 system includes these major steps:

- **Use Existing or Custom Device Drivers.** Every device in the Control4 system needs a corresponding device driver so that controlling the device is possible. When designing and implementing a Control4 system, each time you add a device to a room, a corresponding device driver must be added to the Composer project in the project tree. Device drivers for Control4 products come pre-installed in Composer. In addition, device drivers for hundreds of third-party devices are available through an Online Database, and easily can be added to the project when the driver is available. If a driver for the model you need does not exist, you can use the Driver Creation Wizard (available through a menu option) or DriverWorks (a free add-on utility) to create a custom driver. See the Composer Pro User Guide for details.

**Tip:** If you can't find the device driver you need, you can start with an existing device driver, and modify it for your device using the Driver Creation Wizard.

- **Make the connections.** In the Composer project, you identify all physical device connections to the Control4 system, including control, AV (audio, video), network, and other connections (there are several types of connections). Identifying a device to the system means the Controller acknowledges that the device exists on the home network and can communicate with it and the other devices in the network. You can use Interviewer to complete this task, or use the Connections view in Composer.

- **Register the system at my.control4.com.** Control4 strongly recommends that you register each system you install at my.control4.com to maintain the system software easily through online downloads. Only registered systems can use all of the media services available. In addition, system registration is one of the essential steps in enabling remote access to the system (which also requires a 4Sight subscription).

- **Set up the media.** You identify existing media on the system using the Media view in Composer. The Media view helps you search or scan for movies, videos or music in stored media and auto-generate a list of local broadcast channels, stations, playlists, etc. After you have searched for or scanned in the existing media, you can test Media access through the navigation devices (also known as Navigators).

- **Configure the properties.** You will want to set individual device properties according to your customers' wishes, because most devices have some settings that can be configured (for example, Dimmers that ramp up and down).

- **Program events and actions.** You define interactions between system events and the actions of other devices. For example, when a projector turns on, it can trigger other devices (lights, etc.) in the Home Theater to dim down or turn off.

- **Create the variables and agents for use in programming.** Advanced programming setup options are available to you, including string, Boolean, device properties, variables, delays, and agents. Using these options, you can configure, for example, a 3-way switch, turn equipment on and off with proper delay times, create Lighting Scenes, and perform other desired programming between devices. Advanced programming is discussed in the Composer Pro User Guide.
Customize the Navigators. You complete the registration process and enable Remote Access. You can work with your customers also to set up screen savers and other custom functions on their Navigators.

6.2.1 Purpose of Device Drivers

Every device in the Control4® system needs a corresponding device driver so the device can be controlled by the Control4 system. When you design a system in Composer, the corresponding device driver is added to the project each time you add a new device to a room.

Device drivers for Control4 products come pre-installed in Composer. Device drivers for hundreds of third-party devices are available through an On-line Database and can be added easily to the project. If a driver for the model you need does not exist, you can use the Driver Creation Wizard to create a custom driver.

Note: Creating a device driver is an advanced skill in Composer. For detailed information about how to create a driver, see “Creating Device Drivers” in the Composer Pro User Guide.

6.2.2 Adding Items to the Project Tree

Use the Control4® Composer software to add items (and their device drivers) to a project.

To add items to the project tree or other lists in a Composer project, use one of these methods:

- **Double-click**—After selecting a location in the project tree, double-click an item in the Items pane to add it to a selected location in the project tree.
- **Drag and drop**—Drag and drop items (such as building, floors, rooms, devices, etc.) from the Items pane to the desired location in the project tree. When dragging-and-dropping items, drag the item directly on top of the room or location (such as site, building, floor) in the project tree (left pane) where you want the item to reside.

**Example:** Drag a device (for example, a television) directly on top of the Theater room to ensure it resides in that room.

6.2.3 Building a Project in System Design

Using the Control4® Composer System Design view, you create the foundation of the Control4 system by building a project tree in System Design. As an alternative, you can use Interviewer Wizard to build a project tree, which may be a simpler solution for you if you're new to Composer. **Note:** Only use the Interviewer Wizard for simple projects.

**Tip:** Before you begin to build the system, you may want to assign to all of the devices that will be used in the Control4 system unique and meaningful titles if you used a planning worksheet. That way, they will be easy to identify when you connect them to the home network.

6.2.3.1 Procedure

To build a new project tree in System Design:

1. Start Composer and connect to a Director. A new project opens in the System Design view by default.
2. In System Design, click the Properties tab, and enter the following information:
   - **Name:** Enter homeowner’s name or other project name.
• **Zip Code/Postal Code:** In Lookup, enter the homeowner’s zip code.
• **Latitude and Longitude:** Populated automatically when you enter a zip code or postal code.
• **Date:** Update as needed.
• **Time:** Update as needed.

3. Click to select the project tree.
4. **Add the locations** to the project tree, including sites, buildings, floors, and rooms.

Composer requires this location hierarchy: Site > Building > Floor > Room. The devices will be added to the rooms later.

**Tip:** You do not have to add every level in the hierarchy manually. If you begin building your project tree by adding a room, Composer automatically adds a Building and Floor object for you. You can easily rename these objects in the tree later.

a. In the project tree, select a location (site, building, or floor) where a room exists.

**Example:** The Master Bedroom is on the Second floor, so you would click **Second** to select it. Go to the Items pane and double-click or drag-and-drop **Master Bedroom** to copy it to the project tree.

a. In the Items pane > Locations tab, double-click the **room** you want to add. The room displays in the selected location in the project tree. The room is given a default name, but you can rename it or other location object at any time by right-clicking on the object in the project tree, and choosing **Rename**.

b. Repeat these steps until you have included all of the floors and rooms on each floor in the home to complete your project.

**Example:** Add three (3) rooms to the Main floor.

a. Double-click **Theater** in the Items pane > Locations tab to add a Home > House > Main > Theater to the project tree.

b. Select **Main** in the project tree, then double-click **Bedroom** to add it to the Main floor.

c. With **Main** still highlighted in the project tree, double-click **Front** room to add it to the Main floor.
5. Click the room and add the devices. For example, add the Controller in a room of the project tree.

**IMPORTANT**: Ensure that the devices you select have exact and meaningful titles; for example, "Wireless Dimmer” could be renamed to **East Wall Wireless Dimmer** for easy recognition later. If you have several devices, such as Wireless Dimmers, in the same room give them a unique name.

**Tip**: You can right-click the driver in the project tree to: Rename, Edit Driver, Export Driver, Update Driver, or Delete a driver. Use the same procedure to Update Driver as for Add Driver (see “Driver Menu”).

**Note**: If you installed this version of Composer on a computer that has an older version of Composer, right-click in the white space below the My Driver tab and choose **Restore Default List**. This action updates the My Drivers list.

   a. Click the **room** in the project tree.
   b. From Items pane > My Drivers tab, double-click a **Controller** to move it to the selected room (all devices to be added must be selected from the My Drivers tab).

**Example**: Select the **Theater** room, and then double-click the **Home Controller HC-1000**. The Home Controller HC-1000 and associated Digital Audio objects appear in the project tree. Digital Audio is a component that resides on the Home Controller HC-1000, but shows up as a separate object in the project tree. Digital Audio provides the functionality to play media.
6. Add the Control4 lighting devices and Navigators to the selected room if they reside there.

**Example:** Add the following devices to the Theater room

a. Double-click **Wireless Dimmer**, then rename it to **Dimmer**.

b. Double-click **Wireless Switch**, then rename it to **Light Switch**.

c. Double-click **Wireless Outlet Switch**, then rename it to **TV Outlet Switch**. (This will be used to control the power on a TV that uses an On/Off toggle switch.)

d. Double-click **System Remote Control**.

e. Double-click **6 Button Keypad**.

f. Double-click **LCD Keypad**.

**Note:** If you have a Wireless Touch Screen, add it now to your project.
7. Add all applicable audio and video devices to the selected room.

Here are three examples to follow.

**Example:** Add a Receiver to the Theater room

- Select the **Theater** room in the project tree.
- Double-click **Receiver** in the Audio/Video section of the My Drivers tab. A dialog box displays with **Local Database** selected, and the Receiver drivers that are currently available in the Local Database.
- Choose the Receiver’s **manufacturer** and **model**. In the dialog box, choose Online Database, choose the manufacturer **Harmon Kardon**, and then double-click **AVR230[IR]**.

**Note:** The Receiver object is added to the tree, along with AM Radio, FM Radio, and a Tuner. The next time you choose to add a Receiver to this project, the AVR230[IR] will appear in Local Database driver list.
**Example:** Add a TV to the Theater room

a. Select the **Theater** room in the project tree.

b. Double-click **Television** in the Audio/Video section of the My Drivers tab. A dialog box displays with Local Database selected, and the TV drivers currently available in the Local Database.

c. In the dialog box, choose **Online Database**, choose the manufacturer **Samsung**, and then double-click **TX-P1430[IR]**.

**Note 1:** The UHF/VHF object is added automatically to enable you to scan for UHF/VHF broadcast channels.

**Note 2:** The next time you choose to add a TV to this project, the TX-P1430[IR] appears in the Local Database driver list.

**Example:** Add the DVD Player to the Theater room

a. Select the **Theater** room in the project tree.

b. Double-click **DVD** in the Audio/Video section of My Drivers tab.

c. In the dialog box that appears, choose **Online Database**, choose the manufacturer **Samsung**, and then double-click **DVD HD841[IR]**.

8. **Add Motorized devices or Sensors**, if applicable, to the selected room.

**Example:** From the My Drivers tab, add a **Motorized Screen** and a **Door Contact Sensor** to the Theater room from the Online Database.

a. Select **Theater** in the project tree.

b. In the My Drivers tab under Motorization (scroll down), double-click **Motorized Screen**.
c. In the My Drivers tab under Sensors (scroll down), double-click **Door Contact Sensor**.

![Diagram showing My Drivers tab with Door Contact Sensor highlighted]

9. **Add an HVAC**, if available, to the selected room.

   - Add a Security Panel, if available, to the selected room.
   - Add an IP Camera, if available, to the selected room.
   - Add a Pool and Spa Controller, if available, to the selected room.
   - Add Network File Storage, if available, to the selected room.
   - Repeat Steps 6–8 as needed for each room.

10. Identify and the test the connections. See the **Composer Pro User Guide** for more information.

### 6.2.4 Composer Pro Design Methods

#### 6.2.4.1 Planning a Composer Pro Project: Create a Plan

Before you start to work on a new Control® Composer project (especially if you're new at it) it's best to create a plan. Control4 has provided an **Installation Planning Worksheet** to help you as you start to plan what's going to be needed for a particular customer's home. To go to the worksheet, log in to the Dealer portal, and click **Support > Product Information**. Locate the worksheet in 'Accessories.'

**TIP:** Some of our Dealers use a variety of design tools, for example, AVSnap, Microsoft Visio, AutoCAD, and conceptdraw. AVSnap seems to be the cheapest and the most popular tool.
Here are some suggestions:

1. If you haven't done so yet, take the 'Tech 1 Training' class provided by Control4. Go to training@control4.com for information.
2. Sign up for the Control4 Online Training sessions.
4. Check the Control4 Knowledgebase and Dealer Forums.
5. View the documentation on the Control4 Dealer web site under Support > Product Information.
7. When you've figured out what needs to be done in your customer's home, you'll need to figure out whether you want to use Composer's Interviewer or Composer Views to create your project in Composer.

6.2.4.2 Home Automation Design Methods

6.2.4.2.1 Prerequisites to Creating a Design
Before you begin to create a design for a Control4® system, it's a good idea to create a plan so you know all of the devices in each room, how many rooms there are, how many floors, buildings, the home network structure, and so on.

6.2.4.2.2 Design Tools You Can Use
There are two (2) ways to create a Composer project:

- Using the Interviewer wizard
- Using the System Design view

Both of these tools are in Composer Pro.

6.2.4.2.3 Guidelines of System Design
Consider the following items before you start to design a project for a Control4 automated home.

- Use Existing or Custom Device Drivers. Every device in the system needs a corresponding device driver so the Control4 system can control the device. When designing the system, each time you add a physical device to a room, for example, a DVD player, the corresponding device driver must be added to the project in the project tree. Device drivers for Control4 products are installed with Composer. Device drivers for hundreds of third-party devices are available through an Online-Database, and can be added easily to the project when the driver is available. If a driver for the model of a device does not exist, you can use the Driver Creation Wizard (available through a menu option) or DriverWorks (a free add-on utility) to create a custom driver.
Composer Pro Getting Started

- **Connect and identify the devices to the network.** In the Composer project, you identify all physical connections to the system, including control, AV (audio, video), network, and other connections. You can use Interviewer to complete this task, or go to the Connections view in Composer.

- **Register the system at my.control4.com.** Control4 recommends that you register each system you install at my.control4.com so you can maintain the system software using the online downloads.

**IMPORTANT:** Only registered systems can use all of the media services that are available to Control4 customers. System registration is one of the essential steps in enabling remote access to the system (which also requires a 4Sight subscription).

- **Set up the media.** You identify any existing media on the system using the Media view in Composer. The Media view helps you search or scan stored media and auto-generate a list of local broadcast channels and stations. After you searched or scanned in the existing media, you can test the Media access through the navigation devices (also known as Navigators), and you can create playlists also.

- **Configure properties.** You manage a device’s settings in the Properties pane.

- **Program events and actions.** You define interactions between system events and the actions of other devices. For example, when a projector turns on, it can trigger other devices in the Home Theater to turn on or off causing an event to occur.

- **Create variables and agents for use in programming.** Advanced setup options are available in Composer: string, Boolean, device properties, variables, delays, and agents. Using these options, you can configure, for example, a 3-way switch, turn equipment on and off with proper delay times, create Lighting Scenes, and other customized programming between devices.

- **Customize the Navigators.** You can complete the registration process and enable remote access. You can also work with customers to set up screen savers and other custom functions.

### 6.2.4.3 Ways to Create a Project in Composer Pro

The Control4® Composer interface and wizards are designed to help you simplify the process of designing the system, configuring the devices, making the connections, and programming a Control4 system.

There are two (2) ways to create a project in Composer:

1. **Interviewer Wizard.** This is the easiest way to create simple projects, especially if you're new at this.

2. **Views.** This is the conventional way to create a project. This method is recommended for advanced projects.
6.2.4.4 Using the Interviewer Wizard to Build a Project

The Control4® Interviewer wizard in Composer is the easiest way to guide you through the setup of a project for a Control4 system. The Interviewer wizard is helpful if it is your first time setting up a Control4 system, or if you want to ensure that you set up your project using all of the available options. Interviewer takes you through a complete project setup, covering all of the required setup steps for adding devices and making device connections.

You can create a sample project first using this wizard just to see what is required to build a project. The project is saved in My Documents under Control4/Projects on your PC. You can provide a dummy name.

If you use this method to build a project, the Interviewer wizard will ask you questions, for example, how many rooms are in the home, what controllable devices exist, what type of connections the devices have (such as network, audio/video, or control), and how to access media in the home. When you respond, the Interviewer uses your responses to build and configure a project.

Your project is always viewable in Interviewer. You can modify your project at any time using either the Interviewer wizard or the Composer System Design view.

Interviewer takes you through the following setup process:

- **System Design**—Define your project information and the types of devices on the system.
- **Rooms**—Identify the rooms in your project and each device in a given room.
- **Network**—Identify all of the network connections. Network connections are devices that connect to the Controller hardware using a network address. These include devices such as Control4 Dimmers, Switches, Keypads, Mini Touch Screens, System Remote Controls, and any other device that communicates via ZigBee, ZigBee Pro, TCP/IP or WiFi.
- **Audio/Video**—Define all the audio/video connections on the system. Audio/video connections include any device’s inputs and outputs that carry audio and/or video signals.
- **Control**—Define all the control connections on the system. Control connections include devices that use relay, contacts, IR, or serial for control.

**Note:** Interviewer does not include media setup, configuring, or programming of devices or agents. For more information and example implementations, see "Using the Interviewer Wizard to Build a Project" and "Smith Home—Interviewer Method."

### 6.2.4.4.1 Procedure

To launch the wizard:

1. Start Composer and connect to a Director.
2. From the File menu, choose Run Interview to start the wizard.
3. Follow the on-screen instructions in Interviewer, and respond to the questions as the wizard builds and configures your Control4 system.

4. Be prepared to provide the following system information:
   - Devices in each room that need to be added
   - Device model numbers
   - Types of connections (cabling) between devices

6.2.4.5 Using Composer Views to Build a Project

The Control4® Composer software lets you set up a Control4 system using different Composer views for different tasks. In Composer views, you can add devices, make connections, set up media, and program the system using devices and agents.

**Note:** This method is more detailed than using the Interviewer wizard. If you are new to designing a project, you may want to try the Interviewer wizard method first until you are comfortable with Control4 system setup and configuration. Use Composer Pro views for more advanced projects.

In Composer views, you have the flexibility to follow any setup path you choose as long as a Controller is the first device you add to the project. After you become familiar with the Control4 system and projects, this is the quickest way to set up a project.

**Note:** Before you start to create a project, you will need to understand how to use the views.
6.2.4.5.1 Procedure
To use Composer Views:

1. Start Composer and connect to a Director.


3. If you're unfamiliar with views, review the following sections to learn about each of the views, and then see “Examples Using System Design.”

7. Making and Testing the Connections

7.1 Connecting the Hardware

Before you can design and build a project in Composer, first start by installing the devices and connecting the cables on every device that will be a part of the Control4 system. Otherwise, the devices will not be acknowledged by Composer and Director.

If you purchased equipment from Control4, ensure that you've carefully read the installation or setup instructions and/or user guides included in the box. These instructions will show you how to attach the cables, and in some cases, how to set up and use the device in Composer Pro.
7.2 Testing the Device Connections

When you test a Control4® device connection, you are ensuring that the connection is successful so you don't encounter any problems with devices not functioning later on. You must perform this action for customer satisfaction.

For information about identifying devices and device connections, see the Composer Pro User Guide. The following types of connections may need to be tested on the Control4 system:

- **Network Connections**—Define the devices that use a network address. Network connections include IP and ZigBee or ZigBee Pro devices.
- **Control Connections**—Define the control connection between a device and the Controller. Control connections include contacts, relays, serial, and IR-controlled (infrared) devices.
- **Audio and Video Connections**—Define the devices that have audio and/or video signals.
- **Room Connections**—Define the video, audio, or video/audio **end points** and the video/audio or audio volume for the selected room.

See the Composer Pro User Guide for details.

7.2.1 Testing Network Connections

In the Connections view, click the **Network** tab > IP Network. The list of devices appears.

Make sure there is a network address for every item in the list. If there is not, see "Cannot Identify the Device to the Network" in the Composer Pro User Guide.

7.2.2 Testing Control and AV Connections

In the Connections view, click the **Control/AV** tab. This list of devices appears.

7.2.3 Testing Room Connections

In the Connections view, click the **Control/AV** tab. This list of devices appears in the Room Connections pane.

8. Registering the Control4 System

Every system must be registered at my.control4.com to maintain the system software through online downloads, and to use all of the media features in the system (such as the Control4 online Media Database for scanning music). System registration is also one of the essential first steps in enabling remote access to the system (which also requires a 4Sight subscription).

After you complete the initial Control4® system setup of adding devices to a project, identifying them, and making software connections for each device, you are ready to register the system and set up the media. ("Setting Up the Media" is discussed in the Composer Pro User Guide.)

You can register the system either from Composer or by using a Navigator. See the sections below.
8.1 **Register the System at my.control4.com**

Control4 recommends that you register each Control4 system you install at my.control4.com to maintain the system software easily through online downloads. Only registered systems can use all of the media services available. You must register the Controller, and then register online at my.control4.com. **Note:** The online registration process completes both of these requirements.

System registration, which includes setting up a my.control4.com account, is required to use most of the media services that are available in the Control4 system, for example, scanning media into the system (so that you don't need to manually add individual music files).

**IMPORTANT:** The Control4 system must be functioning correctly before registering. For example, if a Disc Changer does not appear in the left pane, there is not a Disc Changer in the system to add media to it. Contact your Control4 Dealer or Control4 Technical Support if the device does not function as expected in the home network.

You can register the system now through Composer, or later through a Navigator if you customize the Navigator. You may have already registered the system in Composer to set up media. If not, you can register the system using any Internet connection and one of the Navigators that is connected and identified.

### 8.1.1 Register the Controller from Composer

#### 8.1.1.1 Procedure

To use Composer to set up a my.control4.com account and register this Control4 system:

1. In Composer, go to **Tools > Account Services**.
2. Click the **Register your Controller** link to create a my.Control4.com account and start the registration process for the user.
3. Complete the **Create New Account** form for the user according to the instructions on the page, and then record the Account Name, Email Address and Password for the user’s future reference.
4. Click **Create Account** to create an account for this Control4 system.

5. On the Complete Registration page, click **Yes**.

   **Note:** If you click **No**, you cannot scan media in the system, and you must complete the registration at a later time.

6. On the Controller Registration Confirmation page, copy the **10-digit registration code** displayed in the Account Services page in Composer (see next step). This code is time-sensitive and must be used within **10 minutes**. It provides a temporary code used to exchange the security parameters and create a secure connection between my.control4.com and the Controller.

7. On the Account Services page, click the text box and paste the **10-digit registration code** in the box.

8. Click the **Register** button on the Account Services page in Composer (now enabled) to complete the registration. The Current Status changes to 'Registered.'

9. (Optional) When the status is 'Registered,' you can enable or disable remote access. Keep the **Enable Remote Access** box checked to allow Control4 access for system updates and to support remote access to the user's home system through Web Navigator. **Note:** The user must have a 4Sight subscription activated before they can use the Web Navigator.

10. (Temporary Access) To establish a service connection to the Controller for the system you are registering, do the following:
   a. In the current dialog box (**Tools > Account Services**), click **Check In** to request that the system brings up a connection the next time it checks in.
   b. From a connected On-Screen Navigator or Touch Screen, choose **More > Settings > Remote Access > Service Connection**, then select **Check In** (or **Info > Remote Access** on Navigators that use the older interface, for example the Mini Touch Screen). The next time this system checks in for updates, the connection is maintained until you disconnect from its Director in Composer.
8.1.2 Register the System Through a Touch Screen or On-Screen Navigator

8.1.2.1 Procedure

**IMPORTANT:** To complete the registration through a Navigator, the Navigator must be installed, connected to a Controller, and identified in the system.

To use a Navigator to set up a my.Control4.com account and register this system:
2. Click Create Account.
3. Complete the Create New Account form for the user according to the instructions on the page, and then record the Account Name, E-mail Address and Password for the user's future reference.
4. Click Create Account to create an account for this system.
5. On the Complete Registration page, click Yes.
6. On the Controller Registration Confirmation page, copy or write down the **10-digit registration code** displayed. This code is time-sensitive and must be used within **10 minutes.** It provides a temporary code used to exchange security parameters, and set up the ability to create a secure connection between my.control4.com and the Controller.
7. Go to the Navigator's main menu (Home Page), and press More > Settings > Remote Access (or Info > Remote Access on Navigators that use the older interface, for example the Mini Touch Screen).
8. Select the text box in Enter Code, and then enter the **10-digit registration code**.
9. When you are finished, click Done.
10. Choose Activate. When activation is completed, the user can use all media services, such as the online media recognition service.
11. (Optional) While you are here, you may want to enable **Remote Access**. Select **Remote Access > Enable**. This allows Control4 access for system updates and is a required step in enabling user remote access (which also requires a 4Sight subscription, sold separately). If you do not have a 4Sight subscription, you can enable remote access when you do.

8.2 **Setting Up a 4Sight Subscription**

Use the Internet to set up a **4Sight** subscription. This feature enables a Control4 system user to log in to the Internet and manage their Control4® system using Composer on the Web. It also lets you set up remote access and purchase additional Dealer licenses for your Dealers.

*Note:* 4Sight subscriptions are sold separately.

8.2.1 **Prerequisites**

1. Design and set up the project.
2. Register the Control4 System Controller and the system owner.

8.2.2 **Procedure**

When a 4Sight subscription has been obtained for the Control4 system, this setup can be done by the homeowner or Installer. The Installer or a Control4 representative should be able to provide information about how the homeowner can set up a 4Sight account. The *Control4 System User Guide* provides that information for the homeowner.

**To set up a 4Sight subscription at my.control4.com:**

1. Obtain a **4Sight subscription code** for the system (sold separately).
2. Log in to [my.control4.com](http://my.control4.com) using the homeowner/user email address and password.
3. From the My Account tab, select the **Subscriptions** view.
4. Enter the **4Sight subscription code** provided by your Control4 representative, and then click **Activate**.

8.3 **Purchasing and Setting Up Dealer Licenses**

Use the Control4® Web Navigator and my.control4.com to purchase and set up additional Composer Pro licenses for your Dealers and employees who use Composer Pro. You must do this before you run Composer.

**Notes:**

1. Controller registration is separate from a Composer Pro license.
2. This applies to one Controller per account.
3. You cannot assign Composer Pro licenses to consumer accounts; Dealers and employee licenses only.
4. Thirty days after the license is activated, you will be notified to renew the license. You can choose not to or extend the period another 30 days.
8.3.1 Prerequisites

1. Composer Pro must be installed or updated to OS 2.0, and a 4Sight subscription must be set up.
2. A valid Dealer account must be set up.
3. Valid Dealer sub-accounts that the Dealer account manages.

You can find comprehensive information about this subject in the Control4 Knowledgebase. Search for TechDoc00024 Managing Dealer Accounts in my.control4.com.

9. What’s New in Release 2.0?

The Control4® Composer Pro software updates are detailed below. Refer to the Composer Pro Release 2.0 Release Notes for last-minute changes that related to this release.

Highlights:

- New Dealer licensing and the ability to set up Dealer accounts for Composer
- New ‘Pay for Updates’ function
- New Navigator Flash interface
- Improved media management and performance
- ZigBee Pro implementation for the broader market
- Enhanced security via SSL connections
- Internationalization support
- New documentation for Dealers/Installers and homeowners

9.1 Hardware, Software, and Media Support

- A new Flash interface has replaced the interface in Release 1.8.x and earlier. This interface appears on all of the graphical Navigators (Touch Screens and On-Screen Navigators). The Control4 System User Guide and Control4 System Quick Start Guide for Release 2.0 describe how to use this new interface.
- A new Control4 4Store™ has been added to the Navigators. Customers can purchase applications for the Touch Screens and On-Screen Navigators in their Control4 system. See the Control4 System User Guide for details.
- A new IO Extender has been added to the Control4 product line.
- A new Home Controller HC-1000 V3 has been added to the product line.
- Support for AAC music formats (HC-200, HC-300, and HC-500 only).
- Support for Macros, Intercom, and Lighting Scenes in the Agents pane.
- New Macros and Intercom agent.
- Support for page flips, Custom Home page, Favorites, and more on Touch Screens and On-Screen Navigators.
- Programmatic configuration of Screen Saver for On-Screen Navigators.
Certified drivers list. When browsing the Online or Local Database in Composer, the Installer can now distinguish which drivers have been certified by Control4.

9.2 New or Updated Sections

- The Composer and Composer-related documents have been updated and restructured for the Control4 OS 2.0 to make it easier for you to get to the information you need more quickly. Most sections are now available in Web Help or PDF on the Control4 web site as listed below.
- All Help topics have been restructured, reordered, and enhanced.
  - New links, bread crumbs and Glossary pop-ups have been added to the Help topics.
  - Text has been pared down for ease of use and readability.
  - Back and Forward buttons have been added back in.
- The Composer Pro User Guide has been restructured to the following:
  - Composer Pro Getting Started. This document includes how to get set up in Composer and familiarize yourself with the Composer interface. This is a .chm file that is included in the Composer Pro software. It is also available as PDF on the Control4 web site.
  - Composer Pro User Guide (Web Help and PDF). These files include basic and advanced sections. The Help files are available on the Control4 web site as well as in PDF form.
- General network information has been removed. You can get that information from Control4 Training.
- Third-party products may be mentioned, but specific details about how to set them up may not be included. An exception to this, however, is the Black & Decker KwikSet locks.
- Support for Internationalization in the project’s Properties pane.

9.3 Hardware and Software No Longer Supported or Partially Supported

- Home Theater Controller (functions as a Secondary Controller, but not as a Primary Controller; On-Screen Navigator continues to use the legacy interface – prior to OS 2.0).
- Media Controller (functions as a Secondary Controller, but not as a Primary Controller; On-Screen Navigator continues to use the legacy interface – prior to OS 2.0).
- Home Controller HC-1000 V1 (no longer sold by Control4 but fully supported with OS 2.0).
- Home Controller HC-500 (no longer sold by Control4 but fully supported with OS 2.0).
- 10" Wall Mount Touch Screen (will be updated to OS 2.0 but continues to use the Navigators – prior to OS 2.0. This is the last planned update for this device; future support will be limited to compatibility mode).
- 10.5" Wireless Touch Screen V1 (will be updated to OS 2.0 but continues to use the Navigators – prior to OS 2.0. This is the last planned update for this device; future support will be limited to compatibility mode).
- Mini Touch Screen V1 and V2 (will be updated to OS 2.0 but continues to use the Navigators – prior to OS 2.0. This is the last planned update for this device; future support will be limited to compatibility mode).
- Audio products (do not support ZigBee Pro). Use an IP connection for OS 2.0.
- Easy Setup.
- Easy Importer.
Composer Pro Getting Started

- Pool Controller. The Flash-based Navigator UI for pool control is not completed in OS 2.0, although the drivers and proxies remain in place in Composer. If this is important, keep at least one of the older Navigators in your new system for this purpose.
- USB Restore or USB Install. Because an Internet connection is required, these USB utilities are not supported in OS 2.0. Use the 1.7.x or 1.8.2 versions of these utilities. After a restore, you can update to OS 2.0 from 1.7.4 and 1.8.2 to OS 2.0.
- Web Navigator. Rhapsody and 4Store cannot be accessed from the Web Navigator. Use the Touch Screens or On-Screen Navigators.
- The AMG lookup service has been switched to Gracenote®. The Sony 777 Disc Changer uses Gracenote, but the Media Controller can no longer access album, title, or artist information from AMG. CDs, however, can be imported and will show up in the Media Database with a date and time stamp.
- Other Media Managers: You can use other media managers, for example, iTunes, Windows Media Player, and Media Monkey to create MP3s. You can still use Composer ME and Composer HE to add files to Control4.

9.4 Hardware that Doesn’t Support ZigBee® Pro

- Control4 System Remote Control, V1 and V2 (UI not supported in OS 2.0 and will not be updated).
- Contact Relay Extender. Use an IP connection for OS 2.0.
- Audio products: Amps, Switches, Tuners, Speaker Point, etc. Use an IP connection for OS 2.0.

10. Where to Go from Here

This Control4® Composer Pro Getting Started for Release 2.0 (OS 2.0) gives you:

- An overview of Composer: how to install and start it, how to access a Director, and includes a preview of the Composer interface (views, menus, properties, panes, etc.).
- An overview of how to start designing your project and the tools to use.
- An overview about connections and how to test devices.
- How to register the Control4 system.
- How to set up a 4Sight subscription.
- Examples about how to build a system in System Design.

More detailed and advanced sections (Composer Pro User Guide) are outside the scope of this document are located on the Control4 web site.
The advanced sections give you specific details about:
- Setting Up Media
- Creating Device Drivers
- Making Connections
- Verifying Connections
- Configuring Devices
- Configuring Properties
- Basic Programming
- Advanced Programming
- Customizing Navigators
- Installing Devices
- Troubleshooting the System
- Sample Projects

10.1 Contacting Control4 Technical Support
Should you encounter any problems while using Composer Pro, please contact Control4® Technical Support for assistance.
- Phone: 1-888-400-4072
- E-mail: support@control4.com

11. Project Build Examples Using System Design

11.1 Examples Using System Design
Follow the examples provided in these sections to set up devices in a Theater room.

"Example: Using System Design to Add a DVD Player to the Theater Room"
"Example: Using System Design to Add a Receiver to the Theater Room"
"Example: Using System Design to Add a TV to the Theater Room"
"Example: Using System Design to Add Devices to a Theater Room"

11.2 Example: Using System Design to Add Devices to a Theater Room
The following sample project sections step you through the creation of a Control4® project using the Composer Pro views. This example assumes that you’ve already started creating a project that includes a Theater room.
11.2.1 Procedure

To use the Composer System Design view:
1. Start Composer and connect to a Director.
2. Click System Design.

To add the devices:
3. Add the Controller to the Theater room in the project tree.

When setting up a system, first add the Controller to the list. You must attach a Controller to every television you want added to the Control4 system.

In the project tree, choose the room (Theater) where you want the devices with the Controller to reside. In the Items pane > My Drivers tab, double-click a Controller to move it to the room where it resides (for example, HC300).

Note: If you installed this version of Composer on a computer with an older version of Composer, right-click in the My Driver tab, and choose Restore Default List. This will update the My Driver list.

Example: Add a Home Controller to the Theater Room:

From the project tree, select Theater. In the Items pane > My Drivers tab under Controllers, double-click the Controller or drag it to the room where it resides—in this case, the Theater.
4. Add Lighting and User Interface devices to the Theater.

   **Example:** Select Theater in the project tree. In the My Drivers tab, do the following:

   a. In Lighting > Light, double-click Wireless Dimmer, and then rename to Dimmer.
   b. In Lighting > Light, double-click Wireless Switch, and then rename to Light Switch.
   c. In Lighting > Light, double-click Wireless Outlet Switch, and then rename to Television Outlet Switch.
   d. In User Interface, double-click System Remote Control.
   e. In User Interface, double-click 6 Button Keypad.
   f. In User Interface, double-click LCD Keypad.

   **Tip:** Use a descriptive name. When adding devices to the home, right-click and choose Rename to rename them with a descriptive name. For example, if you have two (1) Dimmers in a room, give them a descriptive name such as “Wall Dimmer” or “Ceiling Dimmer.” This helps you identify that specific Dimmer later when identifying connections. If there’s only one Dimmer or Switch in a room, however, you can keep the generic title “Dimmer” or “Switch.”

5. Add a Receiver to the Theater.

   **Example:** Add a Receiver to the Theater room. To add, select Theater in the project tree. From the My Drivers tab, do the following:

   a. In Audio/Video, double-click Receiver.
   b. In the dialog box that appears, choose Online Database, choose the manufacturer Harmon Kardon, and then double-click AVR230[IR].
6. Add a Television to the Theater.
   a. In Motorization, double-click Motorized Screen.
   b. In Sensors, double-click Door Contact Sensor.

Example: Add the Television to the Theater room. To add, select Theater in the project tree. From the My Drivers tab, do the following:

   a. In Audio/Video, double-click Television.
   b. In the dialog box that appears, choose Online Database, choose the manufacturer Samsung, and then double-click TX-P1430[IR].

The UHF/VHF object is added to enable you to scan for UHF/VHF broadcast channels.

7. Add additional Audio/Video devices to the Theater.

Example: Add the DVD Player to the Theater room. To add, select Theater in the project tree. From the My Drivers tab, do the following:

   a. In Audio/Video, double-click DVD.
   b. In the dialog box that appears, choose Online Database, choose the manufacturer Samsung, and then double-click DVD HD841[IR].

Note: If you can access a Wireless Touch Screen, add it now to your project. If you previously had a Wireless Touch screen on your system prior to Release 1.3, follow the special update instructions in “Information About Older Releases” in the Composer Pro User Guide.

8. Add a motorized device or sensor to the Theater.
Example: From the My Drivers tab, add a Motorized screen and a Door Contact Sensor to the Theater room from the Online Database. To add, select Theater in the project tree. In the My Drivers tab, do the following:

a. In Motorization, double-click Motorized Screen.
b. In Sensors, double-click Door Contact Sensor.

11.3 Example: Using System Design to Add a Receiver to the Theater Room

The following sample project steps you through the creation of a Control4® project using the Composer Pro System Design view. This example assumes that you’ve already started creating a project that includes a Theater room.

11.3.1 Procedure

To use the Composer System Design view:
1. Start Composer and connect to a Director.
2. Click System Design.

To add the devices:
3. If you haven’t already done so, add the Controller to the Theater room in the project tree. If you already have added a Controller to the Theater, continue to Step 4.

a. When setting up a system, first add the Controller to the list. You must attach a Controller to every television you want added to the Control4 system.
b. In the project tree, choose the room (Theater) where you want the devices with the Controller to reside. In the Items pane > My Drivers tab, double-click a Controller to move it to the room where it resides (for example, HC300).

Note: If you installed this version of Composer on a computer with an older version of Composer, right-click in the My Driver tab, and choose Restore Default List. This will update the My Driver list.

Example: Add a Home Controller to the Theater Room:

From the project tree, select Theater. In the Items pane > My Drivers tab under Controllers, double-click the Controller or drag it to the room where it resides—in this case, the Theater.
4. Add a **Receiver** to the **Theater**. To add, select **Theater** in the project tree. From the My Drivers tab, do the following:
   
a. In Audio/Video, double-click **Receiver**.
   
b. In the dialog box that appears, choose **Online Database**, choose the manufacturer **Harmon Kardon**, and then double-click **AVR230[IR]**. Notice that the driver is added to the project tree.
11.4 Example: Using System Design to Add a TV to the Theater Room

The following sample project steps you through the creation of a Control4® project using the Composer Pro System Design view. This example assumes that you've already started creating a project that includes a Theater room.

11.4.1 Procedure

To use the Composer System Design view:

1. Start Composer and connect to a Director.
2. Click System Design.

To add the devices:

3. If you haven't already done so, add the Controller to the Theater room in the project tree. If you already have added a Controller to the Theater, continue to Step 4.

   a. When setting up a system, first add the Controller to the list. You must attach a Controller to every television you want added to the Control4 system.

   b. In the project tree, choose the room (Theater) where you want the devices with the Controller to reside. In the Items pane > My Drivers tab, double-click a Controller to move it to the room where it resides (for example, HC300).

   **Note:** If you installed this version of Composer on a computer with an older version of Composer, right-click in the My Driver tab, and choose Restore Default List. This will update the My Driver list.

   **Example:** Add a Home Controller to the Theater Room:

   From the project tree, select Theater. In the Items pane > My Drivers tab under Controllers, double-click the Controller or drag it to the room where it resides—in this case, the Theater.
4. Add a Television to the Theater.
   a. In the Items pane > MyDrivers tab under Motorization, double-click Motorized Screen.
   b. In Sensors, double-click Door Contact Sensor.
   c. In Audio/Video, double-click Television.
   d. In the dialog box that appears, choose Online Database, choose the manufacturer Samsung, and then double-click TX-P1430[IR].

Notice that the driver is added to the project tree. The UHF/VHF object may be added to enable you to scan for UHF/VHF broadcast channels.
11.5 Example: Using System Design to Add a DVD to the Theater Room

The following sample project steps you through the creation of a Control4® project using the Composer Pro System Design view. This example assumes that you've already started creating a project that includes a Theater room.

11.5.1 Procedure

To use the Composer System Design view:
1. Start Composer and connect to a Director.
2. Click System Design.

To add the devices:
3. If you haven't already done so, add the Controller to the Theater room in the project tree. If you already have added a Controller to the Theater, continue to Step 4.

   a. When setting up a system, first add the Controller to the list. You must attach a Controller to every television you want added to the Control4 system.
   
   b. In the project tree, choose the room (Theater) where you want the devices with the Controller to reside. In the Items pane > My Drivers tab, double-click a Controller to move it to the room where it resides (for example, HC300).

Note: If you installed this version of Composer on a computer with an older version of Composer, right-click in the My Driver tab, and choose Restore Default List. This will update the My Driver list.

Example: Add a Home Controller to the Theater Room:

From the project tree, select Theater. In the Items pane > My Drivers tab under Controllers, double-click the Controller or drag it to the room where it resides—in this case, the Theater.
4. Add more audio/video devices to the Theater. To add, select Theater in the project tree. From the My Drivers tab, do the following:
   a. In Audio/Video, double-click DVD.
   b. In the dialog box that appears, choose Online Database, choose the manufacturer Samsung, and then double-click DVD HD841[IR]. Notice that the driver appears in the project tree.
12. Glossary

4

4Sight: An Internet service that provides a connection to the Home-Automation System any time and from any place worldwide.

A


action: An activity that occurs when an event prompts it to do so.

agent: In Control4 programming, agents provide the ability to perform complex programming by using functional modules. There are various types of agents; for example, Announcements, Email Notifications, Scheduler, Lighting Scenes, Wakeup, etc.

AV: Audio Video

C

CD: (Compact Disc) - An optical disc that stores digital data. This format is compatible with Control4 products.

client: A software or hardware device that communicates to a server for feedback from the server via an application for the user.

Command: A 'do' statement; actions the Director communicates to a device.

Composer: The Control4 software used to design and define a Control4 Home-Automation System.

Composer Pro: Composer is used to set up and configure Control4 devices to communicate with each other in a Home-Automation System.

conditional: An 'if' statement that asks a true/false questions which are acted upon in Composer programming.

configuration worksheet: Used in Composer software training to design and configure a project in Composer.

connection: Binding or linking devices together in Composer so they can communicate with each other.

contact: Contacts are generally used to monitor the status of something (door, window, water sensor, etc.) and can be hooked up through a security panel or directly using a Control4 Controller or Contact/Relay Extender. Contacts connected to a Control4 Controller or Contact/Relay Extender can be configured either as NC (normally closed) or NO (normally open).

Control4 system: A Home-Automation System designed and developed by Control4.

Controller: The main device that makes Home Automation possible. There may be multiple Controllers within a Control4 system. The Controller that runs Director is referred to as the Primary Controller.

D

device: A component that requires a device driver; code that is used to allow the Control4 system to work with that device.

device driver: Every device in the Control4 system needs a corresponding device driver to control the device.
DHCP: DHCP (Dynamic Host Configuration Protocol) - A protocol used between a network client and a DHCP server (usually a router or access point) that dynamically assigns IP addresses from a pre-defined list to clients on a network.

Director: Each Control4 Controller (such as a Home Controller HC-500) ships with pre-installed Director software (Linux based) embedded in the device. The Director communicates with Control4 products and third-party products to enable Home Automation and interaction of individual devices. Director runs the Control4 devices. Composer Pro is the software used to connect to and program a system Director that resides on a Controller.

DriverWorks: The DriverWorks SDK is used to create two-way drivers for audio video (AV) and non-AV devices.

DVD: (Digital Versatile Disc) – A media format for video and data storage.

E

event: An action; used to trigger Composer programming when programming Control4 devices.

Ethernet: Uses Ethernet category 5 (CAT5 or CAT5e) wiring to transfer data. Ethernet uses a star network topology that allows multiple points to communicate to a single point. The Speaker Point® and Mini Touch Screens use Ethernet to communicate to the Control4 Controller.

file format: A format used by applications to store/read files.

FLAC: Supported by Control4 for software release 1.8, this is a free, open source, lossless audio codec format that supports tagging, cover art and fast seeking. Audio is compressed with no loss in quality.

G

gateway: (router)- Provides a means of communicating between two separate networks.

home network: A network installed in the customer’s home that provides an Ethernet or wireless connection so that Control4 devices can communicate with each other.

Home-Automation System: The Control4 system: a line of Home Automation products that communicate with each other over Ethernet, WiFi, or ZigBee for a total Home Automation experience.

I

Interviewer Wizard: An automated setup program in Composer that builds a project for Home Automation.

IR: A device controlled using a wireless remote control device. Commands are sent via pulses of infrared light to the device.

L

LCD: (Lighted Crystal Display) - A display used with some Control4 interfaces.

LCD Navigator: An LCD device used to control lighting, music, videos, etc., on an LCD screen.
Linux: An operating system used by several Control4 devices.

List Navigator: A System Remote Control device uses a Navigator that lists the options.

Live Connection: A term used in Composer Pro to indicate an actual connection to the network.

Loop: A type of conditional in programming; a ‘while’ statement; for example, “while the sprinklers are on…”

Media Manager: Media information (metadata) is stored in Media Manager and the Media Database on the Primary Home Controller, which will permit users to view the media from the Navigators.

MP3: A music format that makes streaming audio available.

Navigator: A Control4 Navigator used with the Control4 system to control lights, music, videos, etc. Navigator is software that the customer interacts with using a Universal Remote Control, On-Screen Navigator, Touch Screen, or LCD Screen.

On-Screen Device: Allows you to select the controller (Media Controller or Home Theater Controller) in the room that controls the source for the on-screen display.

playlist: A list of songs compiled in a list. The list can be compiled by songwriter, album, song type, or any combination.

Power Over Ethernet (POE): A Control4 device that is Ethernet controlled.

programming: A machine-readable artificial language used to express computations that can be performed by a device.

project tree: A tree view in Composer where the project is layered by the larger branches (Home, Office, etc.) and then the lower branches (floor, rooms, etc.), and finally to the leaf level (drivers).

ramp rate: The rate that a Dimmer ramps up its voltage.

relay: An electrical switch that opens and closes. A relay is controlled by another electrical circuit.

remote access: The ability to access a device from a remote location.

Remote Director: Connects you to the home network while working in Composer from a remote location.

retrofit: The ability to set up a Home-Automation System in an existing structure or home. Compare this with new building construction.

RJ-45 jack: An eight-pin jack used to connect CAT5e network cables to devices through Ethernet signals.

router: See gateway. Functions similar to an AP but with additional functionality for controlling the network; for example, coordinating traffic between different networks.
**serial-controlled device:** Serial-controlled devices with an RS-232 interface and control protocol often have a higher level of controllability than IR-controlled devices. Examples of serial-controlled devices are projectors, multi-disc DVD changers, etc.

**switch:** An extension of a router that adds more Ethernet ports to support additional devices or clients on the local network.

**system event:** An action that causes another action; for example, if a projector turns on, it enables the other devices in the system that work with the projector.

**system remote:** System Remote Control

**System Remote Control:** A Control4 System Remote Control is a universal solution that replaces System Remote Control devices from other manufacturers, and includes programmable buttons. This System Remote Control can access on-screen (Graphical) Navigators.

**T**

**Touch Screen:** A Touch Screen is a Home-Automation System Navigator that controls the home’s lighting, music, videos, and other devices on the Home-Automation System.

**U**

**UI (user interface):** The preferred term is Navigator. The Control4 interface used with Control4 devices to control Home Automation, such as Touch Screens or On-Screen Navigators.

**universal remote:** Universal remote control. A third-party remote control that can be programmed to replace other remotes in the home so that only one remote is needed, replacing all others. Control4 System Remote Control devices are a type of universal remote control.

**USB:** Universal Serial Bus) - A format used with USB sticks that plug in to a USB port on Control4 devices.

**V**

**Virtual Connection:** A term used in Composer Pro to indicate a connection outside the network.

**Virtual Director:** A connection to a virtual Controller only (a PC is the Director host rather than the Controller). Projects created or edited here are benign until the saved project is loaded onto a Controller.

**W**

**WiFi:** Uses bi-directional wireless technology to transfer data. WiFi (wireless fidelity) devices “connect” to each other by transmitting and receiving signals on a specific frequency of the radio band using a wireless access point. This technology uses the star network topology. WiFi uses high bandwidth 802.11.

**wired network:** Uses Ethernet Category 5 (CAT5) wiring to send and receive data between devices connected to a network.

**wireless access point:** A router extension with an antenna that communicates with WiFi devices and clients in the home. A wireless hub that connects to the wired network, and distributes the wireless signal.

**Wireless Switch:** Uses the ZigBee. UL listed dimmer. Single or multi-gang. Has an air gap to cut power.

**WLAN:** Wireless local area network.
ZigBee: A wireless network that uses bi-directional wireless mesh network technology to transfer messages from one device to another. Unlike a star network topology where devices can only send messages to each other by sending them first to a single central device (which then delivers the message to the recipient device), a mesh network topology allows the devices to forward messages from one device to another, thereby extending the effective range of the network. Uses low bandwidth 802.15.4. 250 devices are allowed per controller but Control4 recommends 125.

ZigBee Pro: The 1.1 version of ZigBee that provides improvements in standardization by: allowing more interoperability with other Control4 devices, support for home automation profiles, and improves the scalability of multiple ZigBee access points.
13. **Index**

10-digit code, registration, 65
10-digit registration code, 108
4Sight, 8
   setup, 110
4Store, 111
AAC, 44
Account Services option, Tools menu, 57
Account Services, Tools menu, 65
Action, programming, example, 48
Actual Playlist options, 45
Add Devices, to project tree, 20
Add Driver option, 53
Add Locations, to project tree, 20
Agents, 101
   Agents pane, 47
   Agents view, 17, 46
   Agents view, from Go menu, 56
   Agents, options, 47
AM/FM/XM, 44
AMG lookup, 113
AMG media lookup service, 43
Audio and video connections, 105
Audio End Point, 25
Audio End Point Devices, 25
Audio Volume, 25
Audio/Video Inputs, Connections view, 40
Audio/Video Outputs, 40
Available Devices pane, 42
Available inputs and outputs pane, 40
Back up Composer, 16
Back up, media information, 78
Backup, 78
   Backup As, 78, 79
   Backup As option, 51
   Backup option, 51
   Backup, project, 74
Basic tasks, 73
Broadcast media types, 44
Build project
   Composer views, 103
   Interviewer Wizard, 93, 102
Build project, System Design, 91
Buildings, Locations tab, 36
Cable TV, 44
CD, 44
Clear Media List, 45
Clear Media List option, 52
Clear project, 74
Clear Project option, 51, 75
Command tab, 49
Communication options, installation, 10
Composer
   register system, 106
Composer HE, 43
Composer ME, 43
Composer Pro activation, 9
Composer Pro interface, 14
Composer Pro requirements, 8
Composer Pro User Guide, 6
Composer Pro views, from Go menu, 55
Composer Pro, defined, 7
Composer Startup screen, 14
Composer views, 17
Composer, back up, 16
Composer, exit program, 16
Composer, older versions, 95
Composer, same version as Director, 90
Conditionals tab, 49
Configuration information, 70
Configuration information, load, 76
Configure properties
   system design, 92
Configure Remote Access
   Director on Local Network, 85
Connect hardware, 104
Connect physical devices, 92
Connect to Director, 80
Connect to Director option, 51
Connected items pane, 40
Connections
   make and test, 104
   Connections view, 17, 38
   Connections view, from Go menu, 56
   Connections, example, 41
   Connections, Properties pane, 70
Contact connection, 7
Contact Control4, 114
Contact Information, 2
Control & Audio Video Connections pane, 38
Control A/V tab, Connections view, 38
Control and AV connection
test, 105
Control connections, 105
Control Inputs, 39, 41
Control Outputs, 41
Control/AV tab, 39
Control4 System, 7
Control4 System User Guide, 6
Controller, 7
Controller registration, 8
Controller, Digital Audio, 44
Controller, playlists, 44
Controller, remove from registration, 66
Copy Existing Driver option, 53
Copyright, 2
Create New Driver option, 53
Create plan, 99
Create variables and agents
  system design, 93
Customize Navigators
  system design, 93
Dealer information, 37
Delete Playlist, 52
Design project
  connect devices, 92
  programming, 92
Design system, 91
Device Actions pane, 49
Device connection status, Tools menu, 56
Device Control window, 20
Device driver, 7
Device driver, Driver Wizard, 54
Device drivers, 100
  and system design, 92
  purpose of, 93
Device Drivers, My Drivers tab, 30
Device drivers, organize, 54
Device Drivers, Search tab, 30
Device Events pane, 49
Device Properties, 69
Device Properties pane, 26
Device Type, 34
Device types, device drivers, 33
Devices, connect, 104
Devices, Properties pane, 70
DHCP, 9
DHCP status, 63
Digital Audio, 44
Direct TV, 44
Director, 7, 42
  Director on Local Network, 82
    live connection, 7
    local connection, 8
    virtual connection, 7
  Virtual mode connection, 81
Director on Local Network, 15, 80
Director, connect to, 80
Director, load configuration, 76
Director, same version as Composer, 90
Directors dialog, 15
Disc Changer, 44, 45
Disclaimer, 2
Disconnect from Director option, 51
Dish Network, 44
DNS server information, 63
Driver
  Delete button, 54
  My Drivers button, 54
  Sort button, 54
Driver Creation Wizard, 92
Driver menu, 49
Driver wizard, 41
Driver, search, 54
Drivers
  Exit button, 54
  Notes, 54
DriverWorks, 41
DVD, 44
DVD Changer, 44
DVD Player, 45
Edit Existing Driver, 41
Edit Existing Driver option, 53
EmberNet Upgrade, Network Tools tab, 57
Enable Remote Access, 84, 108
Endpoints, 24
Ethernet cables, 68
Ethernet connection, 10
Event, programming, example, 48
Example
  add devices to a Theater room, 114
  add devices to Theater room, 95
  add DVD to Theater room, 98, 122
  add motorized screen to Theater room, 98
  add receiver to Theater room, 97, 118
  add thermostat, 99
  add TV to Theater room, 98, 120
Example, system design, 94
Exit Composer, 75
Export Media List, 45, 52
Export Playlist, 45
Export Playlists, 52
File management options, 50
File menu, 49, 78
FLAC, 44
Floors, Locations tab, 36
FM, 44
Gateway, 11, 63
GNU, 2
Go menu, 50, 55
Gracenote, 2
Gracenote lookup, 113
Gracenote media lookup service, 43
Green icon, Network Tools dialog, 58
Hard disk space, 9
Hardware not supported, 112
Hardware, connect, 104
Hardware, install, 9
Help menu, 50
Help options, 69
Home network requirements, 9
Import DVD List from File, 52
Import Media List, 45, 52
Import Playlist, 45
Import Playlists, 52
Info pane, 37
Install hardware, 9
Installation guidelines, 10
Installation Notes, 38
Installation, Composer Pro, 12
Installation, software, 11
Interoperability, 8
Interviewer, 101
Interviewer wizard, 8
Interviewer Wizard, start, 102
Interviewer, limitations, 102
IP address, 9, 42, 63
IP addresses, Directors dialog box, 78
IP Network Connections pane, 42
IP Network tab, 58
IP Network, Network Tools tab, 57
IR, 7
IR driver, 55
Items pane, 19, 28
iTunes, 43
Knowledgebase, 9, 69
LEDs, Controllers, 11
Legal Notice, 2
License, 9
List View pane, 26
List View Properties, 27, 69
List View tab, 73
Load Project option, 51, 77
Load Project, Virtual Director mode, 81
Local Database, device drivers, 34
Local Driver Database, 54
Locale, 23
Localization, 23
Location
  system design, 94
Locations tab, 29, 35
  system design, 94
Longitude/Latitude, 22
  Properties tab, 94
Loops tab, 49
MAC address, 42, 63
Manage Drivers dialog, 53
Manage Drivers option, 53
Manufacturer, device drivers, 34
Media Database, 43, 52
Media Manager, 43
Media menu, 49, 51
Media Monkey, 43
Media pane, 44
Media types, 44
Media view, 17, 43, 101
Media view, from Go menu, 56
Media, select from Navigators, 43
Menu options, 49
Model, device drivers, 35
Movies, can't play, 24
MP3, 44
MP3, on Digital Audio, 44
MPEG, 2
My Drivers tab, 29
my.control4.com, 9
  register system, 106
MyDrivers tab, 121
Navigator tab, 25
Navigator, customize, 101
Network address, 11
Network addresses, address types, 42
Network Configuration Wizard, 60
Network connection, 8
  TCP/IP, 41
  test, 105
Network Connection
  WiFi, 41
  ZigBee, 41
Network connections, 105
Network requirements, 9
Network tab, 40
Network tab, Connections view, 38
Network Tools dialog, 56, 57
Network Tools window, 56
Network, devices discovered, 42
New Playlist, 45, 52
New Project icon, 19
NTP, 22
Online Database, 54
Online Database, device drivers, 35
Overview of, 6
Physical connection, 8
Physical connections, 38
Playlist options, 45
Playlist, types, 44
Power sources, and installation, 10
Program events and actions, 101
  system design, 92
Programming view, 17, 48
Programming view, from Go menu, 56
Programming, actions and events, 48
Project configuration information, 50
Project configuration, back up, 79
Project design methods, 8
Project information, Properties pane, 70
Project properties, 22
Project Properties, 69, 72
Project Settings, 23
Project tree, 8
  add items to, 93
Project, back up, 78
Project, clear, 74
Properties pane, 18, 21, 70, 101
Properties pane, category descriptions, 72
Properties tab, Properties pane, 70
Properties, Composer, 69
Push Settings from Project, 23
Red icon, Network Tools dialog, 58
Refresh Navigators, 51
Refresh option, 51
Register Composer, 13
Register system, 8, 105
  create project, 92
Register your controller, 65
Registration, 65
  from a Navigator, 109
Relay connection, 7
Release 2.0, what's new, 111
Remote Access, 8
  add account, 88
  requirements, 85
Remote Access, setup, 84
Remote connection to Director, 85
Remote Director, 15, 81
  connect to, 87
Remove items from project tree, 74
Rename items in project tree, 74
Rename Playlist, 52
Requirements, 8
Restore Default List, 95
Restore Default List, My Drivers list., 33
RJ-45 jack, 11
Room connection
  test, 105
Room connections, 105
Room Connections, 40
Room Control, 39, 41
Room Properties, 69
Room Properties pane, 24
Room Tree, 59
Rooms, Locations tab, 36
Router, 9, 11
Routing Tree, 59
Run Interview option, 51
Same version, Composer and Director, 90
Scheduler agent, example, 47
Screen Saver, 44
Script pane, 49
Search tab, device drivers, 31
Serial, 7
Serial driver, 55
Set up media
  project design, 92
Site, Locations tab, 36
Software not supported, 112
Songs, 45
Songs, options, 46
SSL, 23
Start Composer Pro, 14
Status information, Properties pane, 70
Storage devices, external, 45
Switch, 11
System design, 8
System Design
  Properties tab, 94
System design guidelines, 100
System design methods, 99
System Design pane, 18, 44
System Design view, 17
System Design view, create project, 8
System Design, Go menu, 56
System Diagnostics, Controller Networking tab, 63
System Diagnostics, Controller Performance
    History button, 62
System Diagnostics, Controller Performance tab,
  61
System Diagnostics, Logging tab, 64
System Diagnostics, System Info tab, 64
System Diagnostics, Test Internet Connection
    button, 63
System Diagnostics, Tools menu, 56
System Manager dialog, Network tab, 60
System Manager dialog, Status tab, 61
System Manager option, Tools menu, 56
System Owner information, 37
System registration, 8
System requirements, 8
System Security, 23
System setup, 7
Tag media files, 52
Tag media files, 52
### Composer Pro Getting Started

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>TCP/IP, 7, 9</td>
<td>7, 9</td>
</tr>
<tr>
<td>Technical Support, contact, 114</td>
<td></td>
</tr>
<tr>
<td>Test connection, 105</td>
<td></td>
</tr>
<tr>
<td>Third-party devices, install, 10</td>
<td></td>
</tr>
<tr>
<td>Timezone, 22</td>
<td></td>
</tr>
<tr>
<td>Tools menu, 12, 50, 56</td>
<td></td>
</tr>
<tr>
<td>UHF/VHF, 44, 98, 121</td>
<td></td>
</tr>
<tr>
<td>Update Manager, 12, 67</td>
<td></td>
</tr>
<tr>
<td>Update Manager option, Tools menu, 57</td>
<td></td>
</tr>
<tr>
<td>Update system, 68</td>
<td></td>
</tr>
<tr>
<td>Upgrade Composer Pro, 11</td>
<td></td>
</tr>
<tr>
<td>USB drive, 44</td>
<td></td>
</tr>
<tr>
<td>User interface, 7</td>
<td></td>
</tr>
<tr>
<td>Variables, 101</td>
<td></td>
</tr>
<tr>
<td>Video End Point, 25</td>
<td></td>
</tr>
<tr>
<td>Video resolution, 9</td>
<td></td>
</tr>
<tr>
<td>Virtual Director, 15, 80</td>
<td></td>
</tr>
<tr>
<td>WAP, 9</td>
<td></td>
</tr>
<tr>
<td>Windows 7, 7</td>
<td></td>
</tr>
<tr>
<td>Windows Media Player, 43</td>
<td></td>
</tr>
<tr>
<td>Windows Vista, 7</td>
<td></td>
</tr>
<tr>
<td>Windows XP, 7</td>
<td></td>
</tr>
<tr>
<td>Wireless Access Protocol, 9</td>
<td></td>
</tr>
<tr>
<td>XM, 44</td>
<td></td>
</tr>
<tr>
<td>Yellow icon, Network Tools dialog, 58</td>
<td></td>
</tr>
<tr>
<td>ZigBee Network tab, 59</td>
<td></td>
</tr>
<tr>
<td>ZigBee Network, Network Tools tab, 57</td>
<td></td>
</tr>
<tr>
<td>ZigBee Pro</td>
<td></td>
</tr>
<tr>
<td>products not supported, 113</td>
<td></td>
</tr>
<tr>
<td>Zip code, Properties tab, 94</td>
<td></td>
</tr>
</tbody>
</table>